aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar bunnei <ericbunnie@gmail.com>2014-04-23 18:43:57 -0700
committerGravatar bunnei <ericbunnie@gmail.com>2014-04-23 18:43:57 -0700
commit4405a53cf3b669e84b1d953d35e89ec29b916293 (patch)
treef6d4370cfce75d9922e75d99c82e1935c6b723c9 /CMakeLists.txt
parent7a136b8a84f9b21e120efe734f86725c46b8531b (diff)
added scm rev generation on Linux/cmake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ed678d61..83a819a7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,6 +29,12 @@ if(NOT DISABLE_QT4)
endif()
endif()
+# generate git revision information
+list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/externals/cmake-modules/")
+include(GetGitRevisionDescription)
+get_git_head_revision(GIT_REF_SPEC GIT_REV)
+git_describe(GIT_DESC --always --long --dirty)
+
# external includes
include_directories(${OPENGL_INCLUDE_DIR})