aboutsummaryrefslogtreecommitdiffhomepage
path: root/third_party/boringssl/src/crypto/rand/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/boringssl/src/crypto/rand/CMakeLists.txt')
-rw-r--r--third_party/boringssl/src/crypto/rand/CMakeLists.txt23
1 files changed, 0 insertions, 23 deletions
diff --git a/third_party/boringssl/src/crypto/rand/CMakeLists.txt b/third_party/boringssl/src/crypto/rand/CMakeLists.txt
deleted file mode 100644
index eedf81b8f3..0000000000
--- a/third_party/boringssl/src/crypto/rand/CMakeLists.txt
+++ /dev/null
@@ -1,23 +0,0 @@
-include_directories(../../include)
-
-if (${ARCH} STREQUAL "x86_64")
- set(
- RAND_ARCH_SOURCES
-
- rdrand-x86_64.${ASM_EXT}
- )
-endif()
-
-add_library(
- rand
-
- OBJECT
-
- rand.c
- urandom.c
- windows.c
-
- ${RAND_ARCH_SOURCES}
-)
-
-perlasm(rdrand-x86_64.${ASM_EXT} asm/rdrand-x86_64.pl)