aboutsummaryrefslogtreecommitdiff
path: root/src/base/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Erwin Jansen <jansene@google.com>2018-11-21 16:09:40 -0800
committerGravatar Erwin Jansen <jansene@google.com>2018-11-27 10:24:19 -0800
commitbaf0508027872f50198e838fe1148b73a9b11b1f (patch)
treec1c350b5ec2b39c1c036e576968a003c84056028 /src/base/CMakeLists.txt
parent16661ba8c0103c2571e84a59a107c9e41dbe60dc (diff)
CMake support to enable compilation under Visual Studio
- Add support for cmake - Template fix to enable compilation with visual studio. - Exclusion of static type tests under visual studio - Fix unit tests due to declaration issues Note we do not build the fuzzing target. Test: All unit tests green on VS2017, MacOs, Linux Change-Id: Ie8437f61d187fff03279c99fde0ff565e8f39b50
Diffstat (limited to 'src/base/CMakeLists.txt')
-rw-r--r--src/base/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/base/CMakeLists.txt b/src/base/CMakeLists.txt
new file mode 100644
index 0000000..2cd27ae
--- /dev/null
+++ b/src/base/CMakeLists.txt
@@ -0,0 +1,27 @@
+# Copyright 2018 Google LLC
+#
+# Licensed under the Apache License Version 2.0 (the License); you may not use
+# this file except in compliance with the License. You may obtain a copy of the
+# License at
+#
+# https://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing software distributed
+# under the License is distributed on an AS IS BASIS WITHOUT WARRANTIES OR
+# CONDITIONS OF ANY KIND either express or implied. See the License for the
+# specific language governing permissions and limitations under the License.
+add_library(base INTERFACE)
+target_include_directories(base INTERFACE ../..)
+
+if(OPTION_ASTC_TESTS)
+ add_executable(base_test
+ test/bit_stream_test.cpp
+ test/bottom_n_test.cpp
+ test/math_utils_test.cpp
+ test/optional_test.cpp
+ test/string_utils_test.cpp
+ test/type_traits_test.cpp
+ test/uint128_test.cpp)
+ target_link_libraries(base_test base gmock_main)
+ add_test(base_test base_test)
+endif()