aboutsummaryrefslogtreecommitdiffhomepage
path: root/absl/random/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Abseil Team <absl-team@google.com>2019-10-16 15:51:11 -0700
committerGravatar Andy Soffer <asoffer@google.com>2019-10-17 14:43:24 -0400
commita15364ce4d88534ae2295127e5d8e32aefb6b446 (patch)
treec01afa5f859f563b7bfd8cfdafa6b6fd1fed3aa6 /absl/random/CMakeLists.txt
parentab3552a18964e7063c8324f45b3896a6a20b08a8 (diff)
Export of internal Abseil changes
-- d35c72d705155dcd89a92835103540f14c643d10 by Gennadiy Rozental <rogeeff@google.com>: helpxml changed to report types of flags with built-in value type. PiperOrigin-RevId: 275131440 -- f3478792943d7dd40a6ef6083a8e5d374f43a65e by Abseil Team <absl-team@google.com>: Add space padding tests for hex conversions. PiperOrigin-RevId: 275120155 -- 7c2e4725403e173660f33f94af686a75d3722936 by Andy Soffer <asoffer@google.com>: Fix https://github.com/abseil/abseil-cpp/issues/379 by renaming `roundup` to `round_up` PiperOrigin-RevId: 275106110 -- 84cb30d6ee509961ac4359cfdda1360973b9527d by Laramie Leavitt <lar@google.com>: Move random_internal::wide_multiply into a file by the same name. PiperOrigin-RevId: 275059359 -- 06d691a8c187b5d899e7863784b23bdcfd580cb2 by Abseil Team <absl-team@google.com>: Add missing "return" keyword. PiperOrigin-RevId: 275036408 GitOrigin-RevId: d35c72d705155dcd89a92835103540f14c643d10 Change-Id: Id837b4de6c9cfe18f0a088363754bfe389df985b
Diffstat (limited to 'absl/random/CMakeLists.txt')
-rw-r--r--absl/random/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/absl/random/CMakeLists.txt b/absl/random/CMakeLists.txt
index 151cefa..19dd2ca 100644
--- a/absl/random/CMakeLists.txt
+++ b/absl/random/CMakeLists.txt
@@ -65,6 +65,7 @@ absl_cc_library(
absl::random_internal_iostream_state_saver
absl::random_internal_traits
absl::random_internal_uniform_helper
+ absl::random_internal_wide_multiply
absl::strings
absl::span
absl::type_traits
@@ -560,6 +561,22 @@ absl_cc_library(
# Internal-only target, do not depend on directly.
absl_cc_library(
NAME
+ random_internal_wide_multiply
+ HDRS
+ "internal/wide_multiply.h"
+ COPTS
+ ${ABSL_DEFAULT_COPTS}
+ LINKOPTS
+ ${ABSL_DEFAULT_LINKOPTS}
+ DEPS
+ absl::bits
+ absl::config
+ absl::int128
+)
+
+# Internal-only target, do not depend on directly.
+absl_cc_library(
+ NAME
random_internal_fastmath
HDRS
"internal/fastmath.h"
@@ -1033,3 +1050,20 @@ absl_cc_test(
absl::random_internal_iostream_state_saver
gtest_main
)
+
+# Internal-only target, do not depend on directly.
+absl_cc_test(
+ NAME
+ random_internal_wide_multiply_test
+ SRCS
+ internal/wide_multiply_test.cc
+ COPTS
+ ${ABSL_TEST_COPTS}
+ LINKOPTS
+ ${ABSL_DEFAULT_LINKOPTS}
+ DEPS
+ absl::random_internal_wide_multiply
+ absl::bits
+ absl::int128
+ gtest_main
+)