aboutsummaryrefslogtreecommitdiffhomepage
path: root/absl/container/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Abseil Team <absl-team@google.com>2019-02-28 09:21:10 -0800
committerGravatar Derek Mauro <dmauro@google.com>2019-03-04 09:41:52 -0500
commit419f3184f8ebcdb23105295eadd2a569f3351eb9 (patch)
tree6ff54227e51347066d376c1e2a5da44801077ae0 /absl/container/CMakeLists.txt
parentb312c3cb53a0aad75a85ac2bf57c4a614fbd48d4 (diff)
Export of internal Abseil changes.
-- 92e1bd6dc9e64163659028b640427d6d8573e41c by Abseil Team <absl-team@google.com>: Don't enable ABSL_HAVE_STD_IS_TRIVIALLY_ASSIGNABLE with MSVC when used with nvcc. With nvcc on Windows __has_trivial_assign(int) is false; that leads to a failure of the check in is_trivially_copy_assignable. A better solution would probably be to use the std-provided check in this case, but that seems like a more intrusive change. PiperOrigin-RevId: 236135209 -- 26cee4a7e647076b4e2f88375b4848d1469e55ed by Derek Mauro <dmauro@google.com>: Remove hashtablez_force_sampling from the open-source release. This should not have been released. It is internal-only and not portable. Fixes https://github.com/abseil/abseil-cpp/issues/268 PiperOrigin-RevId: 235978666 -- 935a885ec0e108963014f1bb79f00102da8f3871 by CJ Johnson <johnsoncj@google.com>: Internal change PiperOrigin-RevId: 235976027 -- 1c148c89de6064031f1ad9f2eeac0331bd77b7b0 by Tom Manshreck <shreck@google.com>: Add design note for absl::from_chars to abseil.io Fixes #165 PiperOrigin-RevId: 235975923 GitOrigin-RevId: 92e1bd6dc9e64163659028b640427d6d8573e41c Change-Id: I220b0bbb46742070ea8c2a94b06007ecae76fe0f
Diffstat (limited to 'absl/container/CMakeLists.txt')
-rw-r--r--absl/container/CMakeLists.txt24
1 files changed, 0 insertions, 24 deletions
diff --git a/absl/container/CMakeLists.txt b/absl/container/CMakeLists.txt
index 822388b..c6053d7 100644
--- a/absl/container/CMakeLists.txt
+++ b/absl/container/CMakeLists.txt
@@ -466,30 +466,6 @@ absl_cc_test(
absl_cc_library(
NAME
- hashtablez_force_sampling
- SRCS
- "internal/hashtablez_force_sampling.cc"
- COPTS
- ${ABSL_DEFAULT_COPTS}
- DEPS
- absl::base
- absl::have_sse
- absl::synchronization
-)
-
-absl_cc_test(
- NAME
- hashtablez_force_sampling_test
- SRCS
- "internal/hashtablez_force_sampling_test.cc"
- DEPS
- absl::hashtablez_force_sampling
- absl::hashtablez_sampler
- gmock_main
-)
-
-absl_cc_library(
- NAME
hashtable_debug
HDRS
"internal/hashtable_debug.h"