aboutsummaryrefslogtreecommitdiffhomepage
path: root/absl/base/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Abseil Team <absl-team@google.com>2018-01-30 13:05:25 -0800
committerGravatar Jon Cohen <cohenjon@google.com>2018-01-30 16:52:52 -0500
commitf4f238b09bc365e355ce404d02c7d7fd02662597 (patch)
tree53e7070c9075cd9ccbdc1c03dd120c8f04348325 /absl/base/CMakeLists.txt
parente5c6ee2d0032d08f4d7a4680c13b9e2e5787ac26 (diff)
Changes imported from Abseil "staging" branch:
- c77facb7ba7c12d656e213e5d63d7dcd9d1f56ba Present the Writer* methods as an option, rather than an ... by Abseil Team <absl-team@google.com> - c6004d718f185868dee2ec48b4de6425399b062d Split exception_safety_testing out into its own cmake rul... by Jon Cohen <cohenjon@google.com> - 9aa6fc7b34674472d808ed8021f3b20faea82f78 Downstream https://github.com/abseil/abseil-cpp/pull/69 by Jon Cohen <cohenjon@google.com> - 13d340269f284b815cc409d2271099e535f4cba4 Internal change by Jon Cohen <cohenjon@google.com> - 51840a9243ac9d47eb3c177398d10bb3341f3230 Fix assertion in conversion from floating point types to ... by Alex Strelnikov <strel@google.com> GitOrigin-RevId: c77facb7ba7c12d656e213e5d63d7dcd9d1f56ba Change-Id: I7590561b04a986ffbec7139bb9c3aea319a3b975
Diffstat (limited to 'absl/base/CMakeLists.txt')
-rw-r--r--absl/base/CMakeLists.txt23
1 files changed, 22 insertions, 1 deletions
diff --git a/absl/base/CMakeLists.txt b/absl/base/CMakeLists.txt
index 9d2de55..4b7b53a 100644
--- a/absl/base/CMakeLists.txt
+++ b/absl/base/CMakeLists.txt
@@ -62,7 +62,6 @@ list(APPEND BASE_INTERNAL_HEADERS
# absl_base main library
list(APPEND BASE_SRC
"internal/cycleclock.cc"
- "internal/exception_safety_testing.cc"
"internal/raw_logging.cc"
"internal/spinlock.cc"
"internal/sysinfo.cc"
@@ -117,6 +116,28 @@ absl_library(
throw_delegate
)
+if(BUILD_TESTING)
+ # exception-safety testing library
+ set(EXCEPTION_SAFETY_TESTING_SRC "internal/exception_safety_testing.cc")
+ set(EXCEPTION_SAFETY_TESTING_PUBLIC_LIBRARIES
+ ${ABSL_TEST_COMMON_LIBRARIES}
+ absl::base
+ absl::memory
+ absl::meta
+ absl::strings
+ absl::types
+ )
+
+absl_library(
+ TARGET
+ absl_base_internal_exception_safety_testing
+ SOURCES
+ ${EXCEPTION_SAFETY_TESTING_SRC}
+ PUBLIC_LIBRARIES
+ ${EXCEPTION_SAFETY_TESTING_PUBLIC_LIBRARIES}
+)
+endif()
+
# dynamic_annotations library
set(DYNAMIC_ANNOTATIONS_SRC "dynamic_annotations.cc")