aboutsummaryrefslogtreecommitdiffhomepage
path: root/absl/base/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Abseil Team <absl-team@google.com>2018-01-24 11:58:42 -0800
committerGravatar John Olson <jolson@google.com>2018-01-24 15:32:49 -0500
commitcf1db73d2ad969f0ebbe6f5ed42678517e493da2 (patch)
treef4d8de3ffd63b3b482d7317a4a635edbe3a27010 /absl/base/CMakeLists.txt
parentdcf112f07409003c325f9cbd4b1dda509acc2359 (diff)
Changes imported from Abseil "staging" branch:
- 0320844dcd8219965647f86db7c6c7296e40e41e Introduce internal macros for inline variable emulation s... by Matt Calabrese <calabrese@google.com> - 85197d0105805e6aab3a0a648351cb1582a61be0 Internal change. by Alex Strelnikov <strel@google.com> GitOrigin-RevId: 0320844dcd8219965647f86db7c6c7296e40e41e Change-Id: I7dce37f6839ff099462951059a9047c5c9377638
Diffstat (limited to 'absl/base/CMakeLists.txt')
-rw-r--r--absl/base/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/absl/base/CMakeLists.txt b/absl/base/CMakeLists.txt
index d306616..9d2de55 100644
--- a/absl/base/CMakeLists.txt
+++ b/absl/base/CMakeLists.txt
@@ -37,6 +37,7 @@ list(APPEND BASE_INTERNAL_HEADERS
"internal/exception_safety_testing.h"
"internal/identity.h"
"internal/invoke.h"
+ "internal/inline_variable.h"
"internal/low_level_alloc.h"
"internal/low_level_scheduling.h"
"internal/malloc_extension.h"
@@ -214,6 +215,26 @@ absl_test(
)
+# test inline_variable_test
+list(APPEND INLINE_VARIABLE_TEST_SRC
+ "internal/inline_variable_testing.h"
+ "inline_variable_test.cc"
+ "inline_variable_test_a.cc"
+ "inline_variable_test_b.cc"
+)
+
+set(INLINE_VARIABLE_TEST_PUBLIC_LIBRARIES absl::base)
+
+absl_test(
+ TARGET
+ inline_variable_test
+ SOURCES
+ ${INLINE_VARIABLE_TEST_SRC}
+ PUBLIC_LIBRARIES
+ ${INLINE_VARIABLE_TEST_PUBLIC_LIBRARIES}
+)
+
+
# test spinlock_test_common
set(SPINLOCK_TEST_COMMON_SRC "spinlock_test_common.cc")
set(SPINLOCK_TEST_COMMON_PUBLIC_LIBRARIES absl::base absl::synchronization)