aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Loo Rong Jie <loorongjie@gmail.com>2017-11-29 08:37:53 +0800
committerGravatar Loo Rong Jie <loorongjie@gmail.com>2017-11-29 08:37:53 +0800
commite98380282fdcd1573d478f380dafa08a15d2f9a5 (patch)
tree2b62c1629a0c3e636ac905ba7cbcc9ae71cf53c9 /CMakeLists.txt
parent79ae60ed9737f6c0ec652eab5492b1359aaea9cf (diff)
Add comments about warning flags
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a740088..c65805e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,8 +27,13 @@ include(AbseilHelpers)
# config options
if (MSVC)
- add_definitions(/DNOMINMAX /DWIN32_LEAN_AND_MEAN=1 /D_CRT_SECURE_NO_WARNINGS)
+ # /wd4005 macro-redefinition
+ # /wd4068 unknown pragma
+ # /wd4244 conversion from 'type1' to 'type2'
+ # /wd4267 conversion from 'size_t' to 'type2'
+ # /wd4800 force value to bool 'true' or 'false' (performance warning)
add_compile_options(/W3 /WX /wd4005 /wd4068 /wd4244 /wd4267 /wd4800)
+ add_definitions(/DNOMINMAX /DWIN32_LEAN_AND_MEAN=1 /D_CRT_SECURE_NO_WARNINGS)
else()
set(ABSL_STD_CXX_FLAG "-std=c++11" CACHE STRING "c++ std flag (default: c++11)")
endif()