aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMake/install_test_project/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Abseil Team <absl-team@google.com>2019-03-20 09:34:39 -0700
committerGravatar Derek Mauro <dmauro@google.com>2019-03-20 15:38:56 -0400
commite75672f6afc7e8f23ee7b532e86d1b3b9be3984e (patch)
tree38bcb6aa1dc3d2390f346aa1a21c4f28229ec78f /CMake/install_test_project/CMakeLists.txt
parentbf29470384a101b307873b26d358433138c857fc (diff)
Export of internal Abseil changes.
-- 61a5128b3b3db9db7df219b7ef737b78f7743e54 by Abseil Team <absl-team@google.com>: Internal change PiperOrigin-RevId: 239413069 -- fd47ba5c2243523cc579239a220254cbc47376af by Jon Cohen <cohenjon@google.com>: Internal change. PiperOrigin-RevId: 239404848 -- bece0ae2b391351feb27547a4693f4e654b1b4ab by Eric Fiselier <ericwf@google.com>: Unconditionally include memory.h in optional. PiperOrigin-RevId: 239298731 GitOrigin-RevId: 61a5128b3b3db9db7df219b7ef737b78f7743e54 Change-Id: I09c1268154f1c8ea2b653d3e907f709e09025817
Diffstat (limited to 'CMake/install_test_project/CMakeLists.txt')
-rw-r--r--CMake/install_test_project/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/CMake/install_test_project/CMakeLists.txt b/CMake/install_test_project/CMakeLists.txt
new file mode 100644
index 0000000..b8e27dd
--- /dev/null
+++ b/CMake/install_test_project/CMakeLists.txt
@@ -0,0 +1,27 @@
+#
+# Copyright 2019 The Abseil Authors.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# https://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+# A simple CMakeLists.txt for testing cmake installation
+
+cmake_minimum_required(VERSION 3.5)
+project(absl_cmake_testing)
+
+set(CMAKE_CXX_STANDARD 11)
+
+add_executable(simple simple.cc)
+
+find_package(absl REQUIRED)
+
+target_link_libraries(simple absl::strings)