aboutsummaryrefslogtreecommitdiffhomepage
path: root/python/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'python/setup.py')
-rwxr-xr-xpython/setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/python/setup.py b/python/setup.py
index f5c00a72..0f4b53c4 100755
--- a/python/setup.py
+++ b/python/setup.py
@@ -172,7 +172,9 @@ if __name__ == '__main__':
# extension. Note that those libraries have to be compiled with
# -fPIC for this to work.
compile_static_ext = get_option_from_sys_argv('--compile_static_extension')
- extra_compile_args = ['-Wno-write-strings', '-Wno-invalid-offsetof']
+ extra_compile_args = ['-Wno-write-strings',
+ '-Wno-invalid-offsetof',
+ '-Wno-sign-compare']
libraries = ['protobuf']
extra_objects = None
if compile_static_ext: