aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 0 insertions, 20 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 27ae32d9..3a926538 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,13 +7,11 @@ IF(APPLE)
set(additional_lib_searchpath
"${CMAKE_CURRENT_SOURCE_DIR}/Externals/ctemplate-osx/lib"
- "${CMAKE_CURRENT_SOURCE_DIR}/Externals/uchardet-osx/lib"
"${CMAKE_CURRENT_SOURCE_DIR}/Externals/libetpan-osx/lib"
)
set(additional_includes
"${CMAKE_CURRENT_SOURCE_DIR}/Externals/ctemplate-osx/include"
- "${CMAKE_CURRENT_SOURCE_DIR}/Externals/uchardet-osx/include"
"${CMAKE_CURRENT_SOURCE_DIR}/Externals/libetpan-osx/include"
/usr/include/tidy
/usr/include/libxml2
@@ -85,24 +83,6 @@ else()
endif()
-# detect uchardet
-
-find_path(UCHARDET_INCLUDE_DIR
- NAMES uchardet/uchardet.h
- PATHS ${additional_includes}
-)
-find_library(UCHARDET_LIBRARY
- NAMES uchardet
- PATHS ${additional_lib_searchpath}
-)
-
-if(NOT UCHARDET_INCLUDE_DIR OR NOT UCHARDET_LIBRARY)
- message(FATAL_ERROR "ERROR: Could not find uchardet")
-else()
- message(STATUS "Found uchardet")
-endif()
-
-
# detect libetpan
find_path(LIBETPAN_INCLUDE_DIR