aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5283a55..83f010b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -194,6 +194,22 @@ fi
AC_CHECK_LIB(dl, dlopen, [EXTRA_LIBS="$EXTRA_LIBS dl"])
AC_SUBST([EXTRA_LIBS])
+# -{l,}pthread goo
+AC_CANONICAL_TARGET
+
+PTHREAD_CFLAGS=
+PTHREAD_LDFLAGS=
+PTHREAD_LIBS=
+case "$host_os" in
+openbsd*)
+ PTHREAD_CFLAGS=-pthread
+ PTHREAD_LDFLAGS=-pthread
+ ;;
+esac
+AC_SUBST(PTHREAD_CFLAGS)
+AC_SUBST(PTHREAD_LDFLAGS)
+AC_SUBST(PTHREAD_LIBS)
+
AC_CONFIG_FILES([unix.buildinfo])
AC_OUTPUT