aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Firestore/CMakeLists.txt')
-rw-r--r--Firestore/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/Firestore/CMakeLists.txt b/Firestore/CMakeLists.txt
index 21bff1f..fe7d8f4 100644
--- a/Firestore/CMakeLists.txt
+++ b/Firestore/CMakeLists.txt
@@ -144,6 +144,26 @@ podspec_framework(
${FIREBASE_SOURCE_DIR}/FirebaseCore.podspec
)
+podspec_framework(
+ ${FIREBASE_SOURCE_DIR}/FirebaseAuthInterop.podspec
+)
+
+# FirebaseAuthInterop has no source files but CMake can't build frameworks that don't
+# have sources. Generate an inconsequential source file so that the library can
+# be linked.
+file(
+ WRITE ${CMAKE_CURRENT_BINARY_DIR}/FirebaseAuthInteropDummy.c
+ "// generated file for header-only CMake support.
+ __attribute__((unused))
+ static void FirebaseAuthInteropFakeSymbol() {}
+ "
+)
+target_sources(
+ FirebaseAuthInterop
+ PRIVATE ${CMAKE_CURRENT_BINARY_DIR}/FirebaseAuthInteropDummy.c
+)
+
+
# Superbuild installed results
include_directories(${FIREBASE_INSTALL_DIR}/include)