aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar zxu <zxu@google.com>2018-02-09 14:28:29 -0500
committerGravatar GitHub <noreply@github.com>2018-02-09 14:28:29 -0500
commitd70c23ece0abf7e1c00166e26fa89a670d34a740 (patch)
treea59b6eb10bd3394fee37cdf59bee0b666b92b3f5 /Firestore/core/CMakeLists.txt
parent633eb7bb8bbce2d31d682bf5255d9ef5a97a29c5 (diff)
port Firestore Auth module in C++ (#733)
* Implement firestore/auth/user * add user to project and some fixes * implement firestore/auth/{credentials_provider,empty_credentials_provider} * implement firestore/auth/firebase_credentials_provider * refactoring firebase_credentials_provider and add (disabled but working) unit test * add auth test to project * address changes * small fix to style and project * fix the firebase_credentials_provider_test * fix style * address changes * revert the change to static mutex_ * remove my custom plist path * fix style * address changes * refactoring FirebaseCredentialsProvider to fix the issue w.r.t. auth global dispatch queue * add /*force_refresh=*/ tag to bool literal for style purpose * Use a shared_ptr/weak_ptr handoff on FirebaseCredentialsProvider (#778) * Revert "refactoring FirebaseCredentialsProvider to fix the issue w.r.t. auth global dispatch queue" This reverts commit 87175a4146267d403a774f138b85f8d3b532fa4b. * Use a shared_ptr/weak_ptr handoff on FirebaseCredentialsProvider This avoids any problems with callsbacks retaining pointers to objects destroyed by a C++ destructor
Diffstat (limited to 'Firestore/core/CMakeLists.txt')
-rw-r--r--Firestore/core/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Firestore/core/CMakeLists.txt b/Firestore/core/CMakeLists.txt
index 2fc88c6..e70647d 100644
--- a/Firestore/core/CMakeLists.txt
+++ b/Firestore/core/CMakeLists.txt
@@ -13,6 +13,7 @@
# limitations under the License.
add_subdirectory(src/firebase/firestore)
+add_subdirectory(src/firebase/firestore/auth)
add_subdirectory(src/firebase/firestore/core)
add_subdirectory(src/firebase/firestore/immutable)
add_subdirectory(src/firebase/firestore/model)
@@ -20,6 +21,7 @@ add_subdirectory(src/firebase/firestore/remote)
add_subdirectory(src/firebase/firestore/util)
add_subdirectory(test/firebase/firestore)
+add_subdirectory(test/firebase/firestore/auth)
add_subdirectory(test/firebase/firestore/core)
add_subdirectory(test/firebase/firestore/immutable)
add_subdirectory(test/firebase/firestore/model)