aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar zxu <zxu@google.com>2018-01-17 13:18:54 -0500
committerGravatar GitHub <noreply@github.com>2018-01-17 13:18:54 -0500
commitcac2c3ff7aa7b94e3776bb1282765ca78be977ae (patch)
tree6234d9795604c8eb362659e4aef9cbd26550619c /Firestore/core/CMakeLists.txt
parent128e9cb170b28bbff0284610276b0e4e517f576e (diff)
implement FieldValue for null, boolean, and array in C++. (#637)
* implement FieldValue for null and boolean. * refactoring to use union type instead of poly * refactor using union design intead of poly * refactoring to use anonymous union and fix styles * small fix * add field_value_test to the project * fix warning of cmake and fix style
Diffstat (limited to 'Firestore/core/CMakeLists.txt')
-rw-r--r--Firestore/core/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/Firestore/core/CMakeLists.txt b/Firestore/core/CMakeLists.txt
index 9291fbd..da08dfc 100644
--- a/Firestore/core/CMakeLists.txt
+++ b/Firestore/core/CMakeLists.txt
@@ -12,8 +12,10 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-add_subdirectory(src/firebase/firestore/util)
+add_subdirectory(src/firebase/firestore/model)
add_subdirectory(src/firebase/firestore/remote)
+add_subdirectory(src/firebase/firestore/util)
-add_subdirectory(test/firebase/firestore/util)
+add_subdirectory(test/firebase/firestore/model)
add_subdirectory(test/firebase/firestore/remote)
+add_subdirectory(test/firebase/firestore/util)