aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar zxu <zxu@google.com>2018-01-25 09:14:19 -0500
committerGravatar GitHub <noreply@github.com>2018-01-25 09:14:19 -0500
commitbfa0e40795ba676fd02d616794cce1c9b2d6a95f (patch)
tree875e86ca1282c275a7f4ad68d03dbc0a2fb22b45 /Firestore/core/CMakeLists.txt
parent1f772120365641eb66f0cc9db9975721c8285d6e (diff)
Implement the rest of FieldValue types for C++ (#687)
* implement FieldValue for null and boolean. * Implement number and string FieldValue. * Implement object FieldValue. * implement timestamp FieldValue. * Implement number and string FieldValue. * implement public type `Blob` and `GeoPoint` * implement Blob FieldValue * Implement GeoPoint FieldValue * refactoring `Blob`
Diffstat (limited to 'Firestore/core/CMakeLists.txt')
-rw-r--r--Firestore/core/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Firestore/core/CMakeLists.txt b/Firestore/core/CMakeLists.txt
index da08dfc..f023446 100644
--- a/Firestore/core/CMakeLists.txt
+++ b/Firestore/core/CMakeLists.txt
@@ -12,10 +12,12 @@
# See the License for the specific language governing permissions and
# limitations under the License.
+add_subdirectory(src/firebase/firestore)
add_subdirectory(src/firebase/firestore/model)
add_subdirectory(src/firebase/firestore/remote)
add_subdirectory(src/firebase/firestore/util)
+add_subdirectory(test/firebase/firestore)
add_subdirectory(test/firebase/firestore/model)
add_subdirectory(test/firebase/firestore/remote)
add_subdirectory(test/firebase/firestore/util)