aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gil <mcg@google.com>2018-01-13 15:21:01 -0800
committerGravatar GitHub <noreply@github.com>2018-01-13 15:21:01 -0800
commitb15283bd27d6ac5eb784efc52ab13bc40b35a625 (patch)
tree6ab34707ec559c45cddff1583f0c44efff49d1ab /Firestore/core/CMakeLists.txt
parentb5454f1a913d246da9e56b4d8e1dd9873d6d65ce (diff)
Build gRPC for Firestore C++ (#652)
* Clean up quoting and other minor issues * Reorganize CMake build output Make it clearer which parts of the output pertain to external projects. * Use a consistent ordering of ExternalProject arguments * Prevent the top-level build from running in parallel This prevents spurious failures when running make -j. * Actually parse arguments in the xcodebuild function * Use ExternalProject features when available * submodule limits from CMake 3.0 * shallow clones from CMake 3.6 * git progress output from CMake 3.8 * Only build the parts of leveldb we need Skip building the tools and other libraries * Avoid installing ExternalProjects Consume build output directly so that we can build just the targets we need. Installing causes all targets to be built. This doesn't matter as much for these targets but the gRPC build includes a ton of stuff we don't need so it's worth adopting this as a general strategy. * Define an external build for grpc * Test that grpc can link successfully. * Add a FindGRPC CMake module * Actually comment ExternalProjext_GitSource
Diffstat (limited to 'Firestore/core/CMakeLists.txt')
-rw-r--r--Firestore/core/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Firestore/core/CMakeLists.txt b/Firestore/core/CMakeLists.txt
index c49b6db..9291fbd 100644
--- a/Firestore/core/CMakeLists.txt
+++ b/Firestore/core/CMakeLists.txt
@@ -13,4 +13,7 @@
# limitations under the License.
add_subdirectory(src/firebase/firestore/util)
+add_subdirectory(src/firebase/firestore/remote)
+
add_subdirectory(test/firebase/firestore/util)
+add_subdirectory(test/firebase/firestore/remote)