aboutsummaryrefslogtreecommitdiffhomepage
path: root/unsupported/doc/snippets/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'unsupported/doc/snippets/CMakeLists.txt')
-rw-r--r--unsupported/doc/snippets/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/unsupported/doc/snippets/CMakeLists.txt b/unsupported/doc/snippets/CMakeLists.txt
index 19e9b1a1f..4a4157933 100644
--- a/unsupported/doc/snippets/CMakeLists.txt
+++ b/unsupported/doc/snippets/CMakeLists.txt
@@ -11,6 +11,9 @@ FOREACH(snippet_src ${snippets_SRCS})
${CMAKE_CURRENT_BINARY_DIR}/${compile_snippet_src})
ADD_EXECUTABLE(${compile_snippet_target}
${CMAKE_CURRENT_BINARY_DIR}/${compile_snippet_src})
+ if(EIGEN_STANDARD_LIBRARIES_TO_LINK_TO)
+ target_link_libraries(${compile_snippet_target} ${EIGEN_STANDARD_LIBRARIES_TO_LINK_TO})
+ endif()
GET_TARGET_PROPERTY(compile_snippet_executable
${compile_snippet_target} LOCATION)
ADD_CUSTOM_COMMAND(