aboutsummaryrefslogtreecommitdiffhomepage
path: root/tvmet-1.7.1/include/tvmet/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tvmet-1.7.1/include/tvmet/CMakeLists.txt')
-rw-r--r--tvmet-1.7.1/include/tvmet/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/tvmet-1.7.1/include/tvmet/CMakeLists.txt b/tvmet-1.7.1/include/tvmet/CMakeLists.txt
index 68d5a5f28..0194b0b6c 100644
--- a/tvmet-1.7.1/include/tvmet/CMakeLists.txt
+++ b/tvmet-1.7.1/include/tvmet/CMakeLists.txt
@@ -7,13 +7,6 @@ INCLUDE (CheckSysvMath)
INCLUDE (CheckLongDouble)
INCLUDE (CheckLongLong)
-# the following are directories where stuff will be installed to
-set(INCLUDE_INSTALL_DIR
- "${CMAKE_INSTALL_PREFIX}/include/tvmet"
- CACHE PATH
- "The subdirectory to the header prefix"
- FORCE)
-
FILE(GLOB tvmet_header_SRCS "*.h")
CHECK_INCLUDE_FILES (sys/time.h TVMET_HAVE_SYS_TIME_H)
@@ -26,6 +19,13 @@ CHECK_SYSV_MATH (TVMET_HAVE_SYSV_MATH)
CHECK_LONG_DOUBLE (TVMET_HAVE_LONG_DOUBLE)
CHECK_LONG_DOUBLE (TVMET_HAVE_LONG_LONG)
+# the following are directories where stuff will be installed to
+set(INCLUDE_INSTALL_DIR
+ "${CMAKE_INSTALL_PREFIX}/include/tvmet"
+ CACHE PATH
+ "The subdirectory to the header prefix"
+ FORCE)
+
CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/config.h.cmake
${INCLUDE_INSTALL_DIR}/config.h)