summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.in b/Makefile.in
index 9347e96f..d021aad1 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -13,7 +13,9 @@ all: smlnj mlton c
smlnj: src/urweb.cm
mlton: bin/urweb
-c: lib/c/urweb.o lib/c/request.o lib/c/driver.o
+
+OBJS := urweb request http
+c: $(OBJS:%=lib/c/%.o)
clean:
rm -f src/*.mlton.grm.* src/*.mlton.lex.* \