summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/compat1
-rw-r--r--debian/control3
-rwxr-xr-xdebian/rules7
3 files changed, 7 insertions, 4 deletions
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index ec635144..00000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-9
diff --git a/debian/control b/debian/control
index 703a8021..a51f91d9 100644
--- a/debian/control
+++ b/debian/control
@@ -4,9 +4,8 @@ Priority: extra
Maintainer: Benjamin Barenblat <bbaren@mit.edu>
Build-Depends:
curl,
- debhelper (>= 9),
+ debhelper-compat (= 13),
default-libmysqlclient-dev,
- dh-autoreconf,
libpq-dev,
libsqlite3-dev,
libssl-dev,
diff --git a/debian/rules b/debian/rules
index 43395a92..2ad9fe75 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,7 +23,7 @@ export MLTONARGS := \
-link-opt "$(shell dpkg-buildflags --get LDFLAGS)"
%:
- dh $@ --parallel --with autoreconf
+ dh $@ --with autoreconf
.PHONY: override_dh_auto_configure
override_dh_auto_configure:
@@ -43,3 +43,8 @@ override_dh_auto_test-indep:
.PHONY: override_dh_auto_install-indep
override_dh_auto_install-indep:
DESTDIR=${CURDIR}/debian/tmp make install-exec-emacs
+
+.PHONY: override_dh_auto_install
+override_dh_auto_install:
+ dh_auto_install
+ find debian/tmp -name \*.la -delete