summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@mit.edu>2015-03-09 19:29:03 -0400
committerGravatar Benjamin Barenblat <bbaren@mit.edu>2015-03-09 19:29:03 -0400
commit2776394a5f58727e03b3a3dcdc2439f8eaad6625 (patch)
treeec796a6eb6c919ef6b7880b304ae9e970137c610 /debian/rules
parent2e1bbc9749f1ad089c0fd366b74646921f35a759 (diff)
Start packaging urweb
Documentation and Emacs files are not generated yet.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..3c670ce5
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+# Avoid overlinking and reduce library dependencies.
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+%:
+ dh $@ --parallel --with autoreconf
+
+.PHONY: override_dh_auto_configure
+override_dh_auto_configure:
+ SRCLIB=/usr/share/urweb dh_auto_configure
+
+.PHONY: override_dh_builddeb
+override_dh_builddeb:
+ dh_builddeb -- -Zxz -z9