summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar Adam Chlipala <adamc@hcoop.net>2008-10-19 12:47:10 -0400
committerGravatar Adam Chlipala <adamc@hcoop.net>2008-10-19 12:47:10 -0400
commit54d7cbad02005212c4171b7d652416c75a93aa37 (patch)
treea51f905aff94143b7019859ff0407d1935e177f9 /Makefile
parent8476261d4f4a9a67119abc05cb40907ad979b4de (diff)
Proper configuration and installation
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile22
1 files changed, 21 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index e78602c6..8e65ea08 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,14 @@
+BIN := /usr/local/bin
+LIB := /usr/local/lib/urweb
+INCLUDE := /usr/local/include/urweb
+SITELISP := /usr/local/share/emacs/site-lisp/urweb-mode
+
+LIB_UR := $(LIB)/ur
+LIB_C := $(LIB)/c
+
all: smlnj mlton c
-.PHONY: all smlnj mlton c clean
+.PHONY: all smlnj mlton c clean install
smlnj: src/urweb.cm
mlton: bin/urweb
@@ -49,3 +57,15 @@ bin/urweb: src/urweb.mlb src/*.sig src/*.sml \
src/urweb.mlton.lex.sml \
src/urweb.mlton.grm.sig src/urweb.mlton.grm.sml
$(MLTON) -output $@ src/urweb.mlb
+
+install:
+ cp bin/urweb $(BIN)/
+ mkdir -p $(LIB_UR)
+ cp lib/*.urs $(LIB_UR)/
+ cp lib/*.ur $(LIB_UR)/
+ mkdir -p $(LIB_C)
+ cp clib/*.o $(LIB_C)/
+ mkdir -p $(INCLUDE)
+ cp include/*.h $(INCLUDE)/
+ mkdir -p $(SITELISP)
+ cp src/elisp/*.el $(SITELISP)/