summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Adam Chlipala <adam@chlipala.net>2019-02-17 09:26:05 -0500
committerGravatar Adam Chlipala <adam@chlipala.net>2019-02-17 09:26:05 -0500
commitf161387682d917484fb3c423adfe9b6ecc376d4d (patch)
tree08613079e555a8b9e5177ea24315d6e69c52693f
parent62dfceb86ba7dfbabb0fabaf89c9cbc8d08afc32 (diff)
New release20190217
-rw-r--r--CHANGELOG15
-rw-r--r--configure.ac4
2 files changed, 17 insertions, 2 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 4e1c1c9e..dc8967db 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,4 +1,19 @@
========
+20190217
+========
+
+- Update of standard-library string functions to handle non-ASCII UTF-8 properly
+- New command-line options: -endpoints
+- New .urp directive: safeGetDefault
+- New Basis functions: textOfBlob, unsafeSerialized[To|From]String
+- New Top functions: mapX4, foldR4
+- New List functions: allM, assocAddSorted, mapConcat, mapConcatM, mapMi, searchM
+- New ListPair functions: mapM, unzip
+- New Option function: mapM
+- Flycheck integration
+- Bug fixes and improvements to type inference, documentation, error messages, and compatibility
+
+========
20180616
========
diff --git a/configure.ac b/configure.ac
index 31bec477..1c738051 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
-AC_INIT([urweb], [20180616])
-WORKING_VERSION=1
+AC_INIT([urweb], [20190217])
+WORKING_VERSION=0
AC_USE_SYSTEM_EXTENSIONS
# automake 1.12 requires this, but automake 1.11 doesn't recognize it