summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@mit.edu>2020-05-30 15:38:23 -0400
committerGravatar Benjamin Barenblat <bbaren@mit.edu>2020-05-30 15:38:23 -0400
commitb02d4b6e386b0e6c02ede532f06ccf615e8b72c5 (patch)
tree4666b6b9ccd4e97ddcb3f5601853d9e790977efe
parente444b6326e3bb1942d9b51e0cdc6bf9350692910 (diff)
Use -D_FORTIFY_SOURCE=1 instead of 2
Prevent major performance regressions by forcing -D_FORTIFY_SOURCE=1 instead of -D_FORTIFY_SOURCE=2. See https://bugs.debian.org/934722 for details.
-rw-r--r--debian/changelog7
-rw-r--r--debian/copyright2
-rwxr-xr-xdebian/rules4
3 files changed, 12 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 68e5b9ab..c840e5eb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+urweb (20170720+dfsg-3) UNRELEASED; urgency=medium
+
+ * Improve performance by using -D_FORTIFY_SOURCE=1 instead of
+ -D_FORTIFY_SOURCE=2. (Closes: #934722)
+
+ -- Benjamin Barenblat <bbaren@mit.edu> Mon, 26 Aug 2019 19:44:41 -0400
+
urweb (20170720+dfsg-2) unstable; urgency=medium
* Disable code hoisting when using MLton’s C codegen. (Closes: #871572)
diff --git a/debian/copyright b/debian/copyright
index f719a549..a70a7fe9 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -10,7 +10,7 @@ Copyright: 2008-2016 Adam Chlipala <adamc@csail.mit.edu>
License: BSD-3-clause
Files: debian/*
-Copyright: 2013, 2014, 2015, 2016 Benjamin Barenblat <bbaren@mit.edu>
+Copyright: 2013, 2014, 2015, 2016, 2019, 2020 Benjamin Barenblat <bbaren@mit.edu>
License: Apache-2.0
Files: debian/*.emacsen*
diff --git a/debian/rules b/debian/rules
index a7ae92ed..43395a92 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,6 +11,10 @@ export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
# arm64 and mips64el. See https://bugs.debian.org/871572 for details.
export DEB_CFLAGS_MAINT_APPEND := -fno-code-hoisting
+# Use -D_FORTIFY_SOURCE=1 instead of -D_FORTIFY_SOURCE=2 to prevent performance
+# problems with %n specifiers. See https://bugs.debian.org/934722 for details.
+export DEB_CPPFLAGS_MAINT_APPEND := -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1
+
# Harden SML executables.
export DEB_BUILD_MAINT_OPTIONS := hardening=+all
export MLTONARGS := \