summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Adam Chlipala <adam@chlipala.net>2020-02-09 10:14:06 -0500
committerGravatar Adam Chlipala <adam@chlipala.net>2020-02-09 10:14:06 -0500
commit5a0b639dfbd7db9d16c6995f72ba17152a1f362d (patch)
tree9296054307f47bb0d7a2e4b5aae75996ca6d50bd
parent1d4a9ff4a9e1cc72573df088e3be35b718c461b9 (diff)
Stop putting extraneous files in release tarballs20200209
-rw-r--r--Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index f0392de0..0aba6781 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -112,9 +112,16 @@ uninstall-local-main:
uninstall-local: uninstall-local-main uninstall-emacs
-EXTRA_DIST = demo doc lib/js lib/ur xml \
+EXTRA_DIST = demo/prose demo/*.urs demo/*.ur demo/*.urp demo/more/prose demo/more/*.urs demo/more/*.ur demo/more/*.urp \
+ doc/Makefile doc/*.tex doc/*.ur doc/LICENSE lib/js \
+ lib/ur/*.urs lib/ur/*.ur xml/parse.sml xml/*.ent \
src/coq src/*.sig src/*.sml src/*.mlb src/config.sml.in src/elisp src/*.cm src/sources src/*.grm src/*.lex \
- CHANGELOG LICENSE urweb.ebuild include/urweb/*.h bin
+ CHANGELOG LICENSE urweb.ebuild include/urweb/*.h tests/*.html
+
+dist-hook:
+ cd src; rm -f urweb.mlton.lex urweb.mlton.grm *.lex.* *.grm.*
+ cd demo; rm -f demo.ur*
+ cd demo/more; rm -f demo.ur*
TESTDB = /tmp/urweb.db
TESTPID = /tmp/urweb.pid