summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Adam Chlipala <adamc@hcoop.net>2010-01-28 20:10:32 -0500
committerGravatar Adam Chlipala <adamc@hcoop.net>2010-01-28 20:10:32 -0500
commitd421272d0b5e813a4646a45666b843c956f4d5eb (patch)
tree59ee5c6dd73bf30d00b25475b5d6bde43b932a08
parenta275b199775b15cd1cb26eb27f2dfbe05faf46a5 (diff)
Small tweaks
-rw-r--r--Makefile.in1
-rw-r--r--lib/ur/basis.urs1
-rw-r--r--src/monoize.sml2
3 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index 6dfc00ab..5729ffac 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -764,6 +764,7 @@ package:
hg archive -t tgz -X tests /tmp/urweb.tgz
reauto:
+ -autoreconf
libtoolize -cf
automake --add-missing --force-missing --copy
autoreconf
diff --git a/lib/ur/basis.urs b/lib/ur/basis.urs
index fe7119a4..5bd97fed 100644
--- a/lib/ur/basis.urs
+++ b/lib/ur/basis.urs
@@ -273,7 +273,6 @@ val check : fs ::: {Type}
-> sql_constraint fs []
-
(*** Queries *)
con sql_query :: {{Type}} -> {Type} -> Type
diff --git a/src/monoize.sml b/src/monoize.sml
index cc239632..21624ab6 100644
--- a/src/monoize.sml
+++ b/src/monoize.sml
@@ -230,7 +230,7 @@ fun monoType env =
(L'.TFfi ("Basis", "string"), loc)
| L.CApp ((L.CApp ((L.CApp ((L.CFfi ("Basis", "sql_binary"), _), _), _), _), _), _) =>
(L'.TFfi ("Basis", "string"), loc)
- | L.CApp ((L.CFfi ("Basis", "sql_aggregate"), _), t) =>
+ | L.CApp ((L.CFfi ("Basis", "sql_aggregate"), _), _) =>
(L'.TFfi ("Basis", "string"), loc)
| L.CApp ((L.CFfi ("Basis", "sql_summable"), _), _) =>
(L'.TRecord [], loc)