diff options
author | Adam Chlipala <adamc@hcoop.net> | 2008-10-25 12:07:10 -0400 |
---|---|---|
committer | Adam Chlipala <adamc@hcoop.net> | 2008-10-25 12:07:10 -0400 |
commit | 1ba5a166755794de2a31af5cdcb1d6ea95f637b9 (patch) | |
tree | 6f85f253789fe06d4e40853ff58aa008295f589e | |
parent | 1d85b75e5d7d18a961c14bfdf38aee339f4f2e05 (diff) |
Use configure --prefix
-rwxr-xr-x | configure | 12 | ||||
-rw-r--r-- | configure.ac | 12 |
2 files changed, 16 insertions, 8 deletions
@@ -1632,20 +1632,24 @@ diagnostic() { true "$@" } +if test $prefix = "NONE"; then + prefix=/usr/local +fi + if test -z $BIN; then - BIN=/usr/local/bin + BIN=$prefix/bin fi if test -z $LIB; then - LIB=/usr/local/lib/urweb + LIB=$prefix/lib/urweb fi if test -z $INCLUDE; then - INCLUDE=/usr/local/include/urweb + INCLUDE=$prefix/include/urweb fi if test -z $SITELISP; then - SITELISP=/usr/local/share/emacs/site-lisp/urweb-mode + SITELISP=$prefix/share/emacs/site-lisp/urweb-mode fi diff --git a/configure.ac b/configure.ac index a0455358..dee2bc1b 100644 --- a/configure.ac +++ b/configure.ac @@ -25,20 +25,24 @@ diagnostic() { true "$@" } +if test [$prefix = "NONE"]; then + prefix=/usr/local +fi + if test [-z $BIN]; then - BIN=/usr/local/bin + BIN=$prefix/bin fi if test [-z $LIB]; then - LIB=/usr/local/lib/urweb + LIB=$prefix/lib/urweb fi if test [-z $INCLUDE]; then - INCLUDE=/usr/local/include/urweb + INCLUDE=$prefix/include/urweb fi if test [-z $SITELISP]; then - SITELISP=/usr/local/share/emacs/site-lisp/urweb-mode + SITELISP=$prefix/share/emacs/site-lisp/urweb-mode fi |