diff options
author | Adam Chlipala <adamc@hcoop.net> | 2008-11-25 15:57:16 -0500 |
---|---|---|
committer | Adam Chlipala <adamc@hcoop.net> | 2008-11-25 15:57:16 -0500 |
commit | a42fe6be6ba6dcb629a6e522624de6506dd7852e (patch) | |
tree | f43f7d0cc86e7897cb9e28540a300e1c877e0efe | |
parent | 940865b04fa534983982b261386a3b1926bd5531 (diff) |
Profiling in Makefile
-rw-r--r-- | .hgignore | 1 | ||||
-rw-r--r-- | Makefile.in | 4 |
2 files changed, 5 insertions, 0 deletions
@@ -26,3 +26,4 @@ demo/out/*.html demo/demo.* *.sql +*mlmon.out diff --git a/Makefile.in b/Makefile.in index ff1f4b6a..a12cb59b 100644 --- a/Makefile.in +++ b/Makefile.in @@ -53,6 +53,10 @@ ifdef DEBUG MLTON += -const 'Exn.keepHistory true' endif +ifdef PROFILE + MLTON += -profile $(PROFILE) +endif + bin/urweb: src/urweb.mlb src/*.sig src/*.sml \ src/urweb.mlton.lex.sml \ src/urweb.mlton.grm.sig src/urweb.mlton.grm.sml |