summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Adam Chlipala <adam@chlipala.net>2016-12-31 15:54:20 -0500
committerGravatar Adam Chlipala <adam@chlipala.net>2016-12-31 15:54:20 -0500
commit1afcd0733b853e4ea089293aed6317e6ebdb43f9 (patch)
treee72d9b7ae374760b97024f8c284a106abd13b980
parent923cc0fcad46eae0a00f7d5c8ea39e627b1aaa57 (diff)
parent71251a24df30b138c3d099c6f375045160b9533d (diff)
Merge branch 'master' of ssh://github.com/urweb/urweb
-rw-r--r--configure.ac1
-rw-r--r--m4/ax_tls.m474
-rw-r--r--src/c/fastcgi.c45
-rw-r--r--src/c/http.c59
4 files changed, 154 insertions, 25 deletions
diff --git a/configure.ac b/configure.ac
index 8ee3e795..0dda6d3b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,6 +12,7 @@ AC_PROG_LIBTOOL()
AC_CONFIG_HEADERS([include/urweb/config.h])
AX_PTHREAD([echo >/dev/null], [echo "Your C compiler does not support POSIX threads."; exit 1])
+AX_TLS([echo >/dev/null], [echo "Your C compiler does not support thread-local storage."; exit 1])
AX_CHECK_OPENSSL([echo >/dev/null], [echo "You must install OpenSSL development files."; exit 1])
diff --git a/m4/ax_tls.m4 b/m4/ax_tls.m4
new file mode 100644
index 00000000..809b761a
--- /dev/null
+++ b/m4/ax_tls.m4
@@ -0,0 +1,74 @@
+# ===========================================================================
+# http://www.gnu.org/software/autoconf-archive/ax_tls.html
+# ===========================================================================
+#
+# SYNOPSIS
+#
+# AX_TLS([action-if-found], [action-if-not-found])
+#
+# DESCRIPTION
+#
+# Provides a test for the compiler support of thread local storage (TLS)
+# extensions. Defines TLS if it is found. Currently knows about GCC/ICC
+# and MSVC. I think SunPro uses the same as GCC, and Borland apparently
+# supports either.
+#
+# LICENSE
+#
+# Copyright (c) 2008 Alan Woodland <ajw05@aber.ac.uk>
+# Copyright (c) 2010 Diego Elio Petteno` <flameeyes@gmail.com>
+#
+# This program is free software: you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the
+# Free Software Foundation, either version 3 of the License, or (at your
+# option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General
+# Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+# As a special exception, the respective Autoconf Macro's copyright owner
+# gives unlimited permission to copy, distribute and modify the configure
+# scripts that are the output of Autoconf when processing the Macro. You
+# need not follow the terms of the GNU General Public License when using
+# or distributing such scripts, even though portions of the text of the
+# Macro appear in them. The GNU General Public License (GPL) does govern
+# all other use of the material that constitutes the Autoconf Macro.
+#
+# This special exception to the GPL applies to versions of the Autoconf
+# Macro released by the Autoconf Archive. When you make and distribute a
+# modified version of the Autoconf Macro, you may extend this special
+# exception to the GPL to apply to your modified version as well.
+
+#serial 11
+
+AC_DEFUN([AX_TLS], [
+ AC_MSG_CHECKING([for thread local storage (TLS) class])
+ AC_CACHE_VAL([ac_cv_tls],
+ [for ax_tls_keyword in __thread '__declspec(thread)' none; do
+ AS_CASE([$ax_tls_keyword],
+ [none], [ac_cv_tls=none ; break],
+ [AC_TRY_COMPILE(
+ [#include <stdlib.h>
+ static void
+ foo(void) {
+ static ] $ax_tls_keyword [ int bar;
+ exit(1);
+ }],
+ [],
+ [ac_cv_tls=$ax_tls_keyword ; break],
+ ac_cv_tls=none
+ )])
+ done
+ ])
+ AC_MSG_RESULT([$ac_cv_tls])
+
+ AS_IF([test "$ac_cv_tls" != "none"],
+ [AC_DEFINE_UNQUOTED([TLS],[$ac_cv_tls],[If the compiler supports a TLS storage class define it to that here])
+ m4_ifnblank([$1],[$1])],
+ [m4_ifnblank([$2],[$2])])
+])
diff --git a/src/c/fastcgi.c b/src/c/fastcgi.c
index cda3e1f6..c37debf7 100644
--- a/src/c/fastcgi.c
+++ b/src/c/fastcgi.c
@@ -1,5 +1,7 @@
#include "config.h"
+#include <assert.h>
+#include <stdint.h>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
@@ -20,6 +22,8 @@
#include "fastcgi.h"
+#define THREAD_LOCAL __thread
+
extern uw_app uw_application;
typedef struct {
@@ -44,6 +48,21 @@ typedef struct {
int available, used, sock;
} FCGI_Input;
+// The FastCGI request ID corresponding to the request being handled by the
+// current worker thread. (Each worker thread can only handle one request at a
+// time.)
+static THREAD_LOCAL int current_request_id;
+
+// Reads the FastCGI request ID from a FastCGI record. The result is guaranteed
+// to be in the range [0, 2^16); this function returns an int to avoid C type
+// promotion insanity.
+static int fastcgi_request_id(const FCGI_Record* const r) {
+ const int requestid = r->requestIdB1 << 8 | r->requestIdB0;
+ assert(requestid >= 0);
+ assert(requestid <= UINT16_MAX);
+ return requestid;
+}
+
static FCGI_Output *fastcgi_output() {
FCGI_Output *o = malloc(sizeof(FCGI_Output));
@@ -70,7 +89,9 @@ static int fastcgi_send(FCGI_Output *o,
unsigned char type,
unsigned short contentLength) {
o->r.type = type;
- o->r.requestIdB1 = o->r.requestIdB0 = 0;
+ assert(current_request_id <= UINT16_MAX);
+ o->r.requestIdB1 = current_request_id >> 8;
+ o->r.requestIdB0 = current_request_id & 0x000000ff;
o->r.contentLengthB1 = contentLength >> 8;
o->r.contentLengthB0 = contentLength & 255;
return uw_really_send(o->sock, &o->r, sizeof(o->r) - 65535 + contentLength);
@@ -356,6 +377,10 @@ static void *worker(void *data) {
goto done;
}
+ // Save the FastCGI request ID this worker is handling so that fastcgi_send
+ // can include it in its response.
+ current_request_id = fastcgi_request_id(r);
+
if (r->type != FCGI_BEGIN_REQUEST) {
write_stderr(out, "First message is not BEGIN_REQUEST\n");
goto done;
@@ -373,6 +398,15 @@ static void *worker(void *data) {
goto done;
}
+ if (fastcgi_request_id(r) != current_request_id) {
+ write_stderr(out,
+ "Ignoring environment variables for request %d (current"
+ " request has id %d)\n",
+ fastcgi_request_id(r),
+ current_request_id);
+ continue;
+ }
+
if (r->type != FCGI_PARAMS) {
write_stderr(out, "Expected FCGI_PARAMS but got %d\n", r->type);
goto done;
@@ -428,6 +462,15 @@ static void *worker(void *data) {
goto done;
}
+ if (fastcgi_request_id(r) != current_request_id) {
+ write_stderr(out,
+ "Ignoring STDIN for request %d (current request has id"
+ " %d)\n",
+ fastcgi_request_id(r),
+ current_request_id);
+ continue;
+ }
+
if (r->type != FCGI_STDIN) {
write_stderr(out, "Expected FCGI_STDIN but got %d\n", r->type);
goto done;
diff --git a/src/c/http.c b/src/c/http.c
index d186e209..1bc58677 100644
--- a/src/c/http.c
+++ b/src/c/http.c
@@ -322,19 +322,28 @@ static void sigint(int signum) {
exit(0);
}
+union uw_sockaddr {
+ struct sockaddr sa;
+ struct sockaddr_in ipv4;
+ struct sockaddr_in6 ipv6;
+};
+
int main(int argc, char *argv[]) {
// The skeleton for this function comes from Beej's sockets tutorial.
int sockfd; // listen on sock_fd
- struct sockaddr_in6 my_addr;
- struct sockaddr_in6 their_addr; // connector's address information
- socklen_t sin_size;
- int yes = 1, no = 0, uw_port = 8080, nthreads = 1, i, *names, opt;
+ union uw_sockaddr my_addr;
+ union uw_sockaddr their_addr; // connector's address information
+ socklen_t my_size = 0, sin_size;
+ int yes = 1, uw_port = 8080, nthreads = 1, i, *names, opt;
int recv_timeout_sec = 5;
signal(SIGINT, sigint);
signal(SIGPIPE, SIG_IGN);
- my_addr.sin6_addr = in6addr_any; // auto-fill with my IP
+ // default if not specified: IPv4 with my IP
+ memset(&my_addr, 0, sizeof my_addr);
+ my_addr.sa.sa_family = AF_INET;
+ my_addr.ipv4.sin_addr.s_addr = INADDR_ANY; // auto-fill with my IP
while ((opt = getopt(argc, argv, "hp:a:A:t:kqT:")) != -1) {
switch (opt) {
@@ -357,20 +366,17 @@ int main(int argc, char *argv[]) {
break;
case 'a':
- {
- char *buf = alloca(strlen(optarg) + 8);
- strcpy(buf, "::FFFF:");
- strcpy(buf + 7, optarg);
- if (!inet_pton(AF_INET6, buf, &my_addr.sin6_addr)) {
- fprintf(stderr, "Invalid IPv4 address\n");
- help(argv[0]);
- return 1;
- }
+ my_addr.sa.sa_family = AF_INET;
+ if (!inet_pton(AF_INET, optarg, &my_addr.ipv4.sin_addr)) {
+ fprintf(stderr, "Invalid IPv4 address\n");
+ help(argv[0]);
+ return 1;
}
break;
case 'A':
- if (!inet_pton(AF_INET6, optarg, &my_addr.sin6_addr)) {
+ my_addr.sa.sa_family = AF_INET6;
+ if (!inet_pton(AF_INET6, optarg, &my_addr.ipv6.sin6_addr)) {
fprintf(stderr, "Invalid IPv6 address\n");
help(argv[0]);
return 1;
@@ -413,7 +419,7 @@ int main(int argc, char *argv[]) {
names = calloc(nthreads, sizeof(int));
- sockfd = socket(AF_INET6, SOCK_STREAM, 0); // do some error checking!
+ sockfd = socket(my_addr.sa.sa_family, SOCK_STREAM, 0); // do some error checking!
if (sockfd < 0) {
fprintf(stderr, "Listener socket creation failed\n");
@@ -425,15 +431,20 @@ int main(int argc, char *argv[]) {
return 1;
}
- if (setsockopt(sockfd, IPPROTO_IPV6, IPV6_V6ONLY, &no, sizeof(int)) < 0) {
- fprintf(stderr, "Listener IPV6_V6ONLY option resetting failed\n");
- return 1;
+ switch (my_addr.sa.sa_family)
+ {
+ case AF_INET:
+ my_size = sizeof(my_addr.ipv4);
+ my_addr.ipv4.sin_port = htons(uw_port);
+ break;
+
+ case AF_INET6:
+ my_size = sizeof(my_addr.ipv6);
+ my_addr.ipv6.sin6_port = htons(uw_port);
+ break;
}
- my_addr.sin6_family = AF_INET6; // host byte order
- my_addr.sin6_port = htons(uw_port); // short, network byte order
-
- if (bind(sockfd, (struct sockaddr *)&my_addr, sizeof my_addr) < 0) {
+ if (bind(sockfd, &my_addr.sa, my_size) < 0) {
fprintf(stderr, "Listener socket bind failed\n");
return 1;
}
@@ -470,7 +481,7 @@ int main(int argc, char *argv[]) {
}
while (1) {
- int new_fd = accept(sockfd, (struct sockaddr *)&their_addr, &sin_size);
+ int new_fd = accept(sockfd, &their_addr.sa, &sin_size);
if (new_fd < 0) {
qfprintf(stderr, "Socket accept failed\n");