summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Adam Chlipala <adamc@hcoop.net>2008-11-25 15:57:16 -0500
committerGravatar Adam Chlipala <adamc@hcoop.net>2008-11-25 15:57:16 -0500
commit3dc21c1120b2cffcfe325ae0f527a014a7ccf107 (patch)
treef43f7d0cc86e7897cb9e28540a300e1c877e0efe
parent1ac88954071855f6d59011a7d2b4a44622b09458 (diff)
Profiling in Makefile
-rw-r--r--.hgignore1
-rw-r--r--Makefile.in4
2 files changed, 5 insertions, 0 deletions
diff --git a/.hgignore b/.hgignore
index 8c3417d4..b388b26a 100644
--- a/.hgignore
+++ b/.hgignore
@@ -26,3 +26,4 @@ demo/out/*.html
demo/demo.*
*.sql
+*mlmon.out
diff --git a/Makefile.in b/Makefile.in
index ff1f4b6a..a12cb59b 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -53,6 +53,10 @@ ifdef DEBUG
MLTON += -const 'Exn.keepHistory true'
endif
+ifdef PROFILE
+ MLTON += -profile $(PROFILE)
+endif
+
bin/urweb: src/urweb.mlb src/*.sig src/*.sml \
src/urweb.mlton.lex.sml \
src/urweb.mlton.grm.sig src/urweb.mlton.grm.sml