summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am55
1 files changed, 47 insertions, 8 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c31c94d..00853af 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -6,6 +6,11 @@ public_icons_themes = \
public_icons = \
hicolor_apps_scalable_transmission-remote-gtk.svg \
+ hicolor_apps_16x16_transmission-remote-gtk.png \
+ hicolor_apps_24x24_transmission-remote-gtk.png \
+ hicolor_apps_48x48_transmission-remote-gtk.png \
+ hicolor_apps_22x22_transmission-remote-gtk.png \
+ hicolor_apps_32x32_transmission-remote-gtk.png \
$(NULL)
EXTRA_DIST = transmission-remote-gtk.desktop.in
@@ -20,14 +25,48 @@ schema_DATA = transmission-remote-gtk.schemas
bin_PROGRAMS = transmission-remote-gtk
INCLUDES = --pedantic -Wall -I.. -O2 $(jsonglib_CFLAGS) $(gthread_CFLAGS) $(gtk_CFLAGS) $(gconf_CFLAGS) $(gio_CFLAGS) $(unique_CFLAGS) $(notify_CFLAGS)
-transmission_remote_gtk_SOURCES = main.c requests.c base64.c json.c http.c dispatch.c trg-main-window.c util.c trg-about-window.c torrent.c \
- tpeer.c tfile.c session-get.c trg-client.c trg-preferences-dialog.c hig.c trg-torrent-tree-view.c \
- trg-tree-view.c trg-torrent-model.c trg-peers-model.c trg-peers-tree-view.c trg-model.c trg-files-model.c \
- trg-files-tree-view.c trg-state-selector.c trg-general-panel.c trg-toolbar.c trg-menu-bar.c \
- trg-status-bar.c trg-trackers-tree-view.c trg-trackers-model.c trg-torrent-props-dialog.c \
- trg-json-widgets.c trg-torrent-add-url-dialog.c trg-cell-renderer-speed.c trg-cell-renderer-size.c \
- trg-cell-renderer-ratio.c trg-cell-renderer-eta.c trg-remote-prefs-dialog.c trg-cell-renderer-wanted.c \
- trg-cell-renderer-priority.c
+transmission_remote_gtk_SOURCES = main.c \
+ requests.c \
+ base64.c \
+ json.c \
+ http.c \
+ dispatch.c \
+ trg-main-window.c \
+ util.c \
+ trg-about-window.c \
+ torrent.c \
+ tpeer.c \
+ tfile.c \
+ session-get.c \
+ trg-client.c \
+ trg-preferences-dialog.c \
+ hig.c \
+ trg-torrent-tree-view.c \
+ trg-tree-view.c \
+ trg-torrent-model.c \
+ trg-peers-model.c \
+ trg-peers-tree-view.c \
+ trg-model.c \
+ trg-files-model.c \
+ trg-files-tree-view.c \
+ trg-state-selector.c \
+ trg-general-panel.c \
+ trg-toolbar.c \
+ trg-menu-bar.c \
+ trg-status-bar.c \
+ trg-trackers-tree-view.c \
+ trg-trackers-model.c \
+ trg-torrent-props-dialog.c \
+ trg-json-widgets.c \
+ trg-torrent-add-url-dialog.c \
+ trg-cell-renderer-speed.c \
+ trg-cell-renderer-size.c \
+ trg-cell-renderer-ratio.c \
+ trg-cell-renderer-eta.c \
+ trg-remote-prefs-dialog.c \
+ trg-cell-renderer-wanted.c \
+ trg-cell-renderer-priority.c \
+ $(NULL)
transmission_remote_gtk_LDFLAGS = -lcurl $(jsonglib_LIBS) $(gtk_LIBS) $(gthread_LIBS) $(GEOIP_LIBS) $(gconf_LIBS) $(gio_LIBS) $(unique_LIBS) $(notify_LIBS)