summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules17
1 files changed, 17 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..128cace
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+# Avoid overlinking and reduce library dependencies.
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+%:
+ dh $@ --with autoreconf
+
+.PHONY: override_dh_autoreconf
+override_dh_autoreconf:
+ dh_autoreconf /usr/bin/env -- NOCONFIGURE=1 ./autogen.sh
+
+.PHONY: override_dh_auto_configure
+override_dh_auto_configure:
+ dh_auto_configure -- --without-libappindicator --without-libmrss \
+ --disable-debug --disable-silent-rules