summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/avoidRssGlib.diff43
-rw-r--r--debian/patches/series2
-rw-r--r--debian/patches/validateAppdata.diff24
3 files changed, 69 insertions, 0 deletions
diff --git a/debian/patches/avoidRssGlib.diff b/debian/patches/avoidRssGlib.diff
new file mode 100644
index 0000000..fbc156e
--- /dev/null
+++ b/debian/patches/avoidRssGlib.diff
@@ -0,0 +1,43 @@
+Subject: Don't touch rss-glib if RSS is disabled
+
+rss-glib is licensed under the LGPLv3 or later. src/hig.c, src/hig.h,
+src/torrent-cell-renderer.c, and src/torrent-cell-renderer.h are licensed under
+the GPLv2 only. Therefore, transmission-remote-gtk must be built without RSS to
+avoid a GPL violation.
+
+Disabling RSS with --without-libmrss should be enough to ensure this happens.
+In the interest of defence in depth, however, conditionalize references to
+rss-glib from within the build system. As an added bonus, this speeds up build
+time by not building code which will never get linked.
+
+Author: Benjamin Barenblat <bbaren@mit.edu>
+Bug: https://github.com/transmission-remote-gtk/transmission-remote-gtk/issues/21
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -20,7 +20,10 @@
+ ACLOCAL_AMFLAGS = -I m4
+ AUTOMAKE_OPTIONS = foreign
+ DISTCHECK_CONFIGURE_FLAGS = --disable-desktop-database-update
+-SUBDIRS = extern src po data
++SUBDIRS = src po data
++if HAVE_RSS
++SUBDIRS += extern
++endif
+
+ DISTCLEANFILES = \
+ intltool-extract \
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -143,8 +143,10 @@
+ icon-turtle.h
+
+ transmission_remote_gtk_CPPFLAGS = \
+- -DLOCALEDIR=\""$(localedir)"\" \
+- -I$(top_srcdir)/extern
++ -DLOCALEDIR=\""$(localedir)"\"
++if HAVE_RSS
++transmission_remote_gtk_CPPFLAGS += -I$(top_srcdir)/extern
++endif
+
+ transmission_remote_gtk_CFLAGS = \
+ $(TRG_CFLAGS) \
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..8afeb66
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+avoidRssGlib.diff
+validateAppdata.diff
diff --git a/debian/patches/validateAppdata.diff b/debian/patches/validateAppdata.diff
new file mode 100644
index 0000000..ea6dd07
--- /dev/null
+++ b/debian/patches/validateAppdata.diff
@@ -0,0 +1,24 @@
+Description: Correct style errors in transmission-remote-gtk.appdata.xml
+Author: Benjamin Barenblat <bbaren@mit.edu>
+Bug: https://github.com/transmission-remote-gtk/transmission-remote-gtk/issues/37
+Forwarded: no
+--- a/data/transmission-remote-gtk.appdata.xml.in
++++ b/data/transmission-remote-gtk.appdata.xml.in
+@@ -14,14 +14,10 @@
+ <description>
+ <_p>
+ Transmission Remote Gtk allows you to remotely manage the Transmission BitTorrent client using its RPC interface.
++ It is a full featured client, allowing adding, starting, stopping, removing, verifying, and reannouncing torrents.
++ It also exposes settings for both individual torrents (peer limits, file priorities, tracker settings, etc.) and Transmission as a whole (global limits, download directory, connectivity preferences, etc.)
++ It can also act as a .torrent handler, opening when torrents are downloaded through a web browser.
+ </_p>
+- <_p>Features:</_p>
+- <ul>
+- <_li>Remotely add (file/url), start, stop, remove, remove and delete, verify, reannounce torrents</_li>
+- <_li>Works as a .torrent handler (eg. from a web browser)</_li>
+- <_li>Set torrent properties such as speed, seed, peer limits, file priorities, add/edit/remove trackers</_li>
+- <_li>Change remote settings like global limits, download directory, and connectivity preferences</_li>
+- </ul>
+ </description>
+ <screenshots>
+ <screenshot height="576" width="1024" type="default">