summaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
new file mode 100644
index 0000000..852a02d
--- /dev/null
+++ b/data/Makefile.am
@@ -0,0 +1,15 @@
+SUBDIRS = icons
+
+desktop_in_files = transmission-remote-gtk.desktop.in
+desktop_FILES = $(desktop_in_files:.desktop.in=.desktop)
+@INTLTOOL_DESKTOP_RULE@
+@DESKTOP_FILE_RULES@
+
+appstream_in_files = transmission-remote-gtk.appdata.xml.in
+appstream_XML = $(appstream_in_files:.xml.in=.xml)
+@INTLTOOL_XML_RULE@
+@APPSTREAM_XML_RULES@
+
+EXTRA_DIST = $(desktop_in_files) $(appstream_in_files)
+
+DISTCLEANFILES = $(desktop_FILES) $(appstream_XML)