summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@debian.org>2020-04-20 19:09:19 -0400
committerGravatar Benjamin Barenblat <bbaren@debian.org>2020-04-20 19:12:39 -0400
commit6d0dc6d70284b8500476fe43ce0e4d7c3179bdf5 (patch)
tree2c51c6efd7e66d26e73c7c8b1e2e6d1bd0f6616c
parent347063512721dfa6252af0fbd2869576f595c761 (diff)
Fix building with `-fno-common`
Backport a patch from upstream to unbreak the build with `-fno-common` (as set by default in GCC 10).
-rw-r--r--debian/changelog6
-rw-r--r--debian/copyright4
-rw-r--r--debian/patches/fno-common.diff20
-rw-r--r--debian/patches/series1
4 files changed, 31 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 665f099..e296625 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+transmission-remote-gtk (1.4.1-3) UNRELEASED; urgency=medium
+
+ * Fix building with GCC 10 (closes: #957883).
+
+ -- Benjamin Barenblat <bbaren@debian.org> Mon, 20 Apr 2020 19:05:06 -0400
+
transmission-remote-gtk (1.4.1-2) unstable; urgency=medium
* Delete unused build dependency on libunique-dev (closes: #947516).
diff --git a/debian/copyright b/debian/copyright
index a8ae2b0..583c902 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -33,6 +33,10 @@ Files: debian/*
Copyright: 2013-2018 Benjamin Barenblat <bbaren@debian.org>
License: Apache-2.0
+Files: debian/patches/fno-common.diff
+Copyright: 2020 David Seifert <soap@gentoo.org>
+License: GPL-2+
+
Files: extern/rss-glib/*.c extern/rss-glib/*.h
Copyright: 2008 Christian Hergert <chris@dronelabs.com>
License: LGPL-3+
diff --git a/debian/patches/fno-common.diff b/debian/patches/fno-common.diff
new file mode 100644
index 0000000..7804731
--- /dev/null
+++ b/debian/patches/fno-common.diff
@@ -0,0 +1,20 @@
+From: David Seifert <soap@gentoo.org>
+Subject: Fix building under GCC 10 / -fno-common
+Origin: upstream, https://github.com/transmission-remote-gtk/transmission-remote-gtk/commit/b20655081332847426a7d10189bb1e2369efea42
+Bug-Debian: https://bugs.debian.org/957883
+Bug-Gentoo: https://bugs.gentoo.org/706980
+Forwarded: https://github.com/transmission-remote-gtk/transmission-remote-gtk/pull/92
+Applied-Upstream: https://github.com/transmission-remote-gtk/transmission-remote-gtk/commit/b20655081332847426a7d10189bb1e2369efea42
+
+Add a `typedef` to avoid defining a variable.
+--- a/src/trg-tree-view.h
++++ b/src/trg-tree-view.h
+@@ -51,7 +51,7 @@ GtkWidget *trg_tree_view_new(void);
+
+ G_END_DECLS GList *trg_tree_view_get_selected_refs_list(GtkTreeView * tv);
+
+-enum {
++typedef enum {
+ TRG_COLTYPE_ICONTEXT,
+ TRG_COLTYPE_FILEICONTEXT,
+ TRG_COLTYPE_WANTED,
diff --git a/debian/patches/series b/debian/patches/series
index 77643e8..066417a 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
avoidRssGlib.diff
appdataContentRating.diff
validateAppdata.diff
+fno-common.diff