summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@debian.org>2018-11-23 12:32:30 -0500
committerGravatar Benjamin Barenblat <bbaren@debian.org>2018-11-23 13:07:03 -0500
commit268cdb6e5a1b6d4a641e9b3b18f739de51f2f3bd (patch)
tree794bbb17577a8a4381dc6aad6568cfee7d65c586
parent4ee6d1d800d8bdb13b6adfc62df359b22a35b458 (diff)
Refresh patches
-rw-r--r--debian/patches/avoidRssGlib.diff10
-rw-r--r--debian/patches/validateAppdata.diff24
2 files changed, 17 insertions, 17 deletions
diff --git a/debian/patches/avoidRssGlib.diff b/debian/patches/avoidRssGlib.diff
index aa87654..9132f89 100644
--- a/debian/patches/avoidRssGlib.diff
+++ b/debian/patches/avoidRssGlib.diff
@@ -10,7 +10,7 @@ In the interest of defence in depth, however, conditionalize references to
rss-glib from within the build system. As an added bonus, this speeds up build
time by not building code which will never get linked.
-Author: Benjamin Barenblat <bbaren@debian.org>
+Author: Benjamin Barenblat <bbaren@mit.edu>
Bug: https://github.com/transmission-remote-gtk/transmission-remote-gtk/issues/21
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,14 +18,14 @@ Bug: https://github.com/transmission-remote-gtk/transmission-remote-gtk/issues/2
ACLOCAL_AMFLAGS = -I m4
AUTOMAKE_OPTIONS = foreign
DISTCHECK_CONFIGURE_FLAGS = --disable-desktop-database-update
--SUBDIRS = extern src po data
-+SUBDIRS = src po data
+-SUBDIRS = extern src data po
++SUBDIRS = src data po
+if HAVE_RSS
+SUBDIRS += extern
+endif
- DISTCLEANFILES = \
- intltool-extract \
+ EXTRA_DIST = config.rpath README.md
+
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -143,8 +143,10 @@
diff --git a/debian/patches/validateAppdata.diff b/debian/patches/validateAppdata.diff
index e266c67..1980e14 100644
--- a/debian/patches/validateAppdata.diff
+++ b/debian/patches/validateAppdata.diff
@@ -1,23 +1,23 @@
-Description: Correct style errors in transmission-remote-gtk.appdata.xml
-Author: Benjamin Barenblat <bbaren@debian.org>
+Description: Correct style errors in io.github.TransmissionRemoteGtk.appdata.xml
+Author: Benjamin Barenblat <bbaren@mit.edu>
Bug: https://github.com/transmission-remote-gtk/transmission-remote-gtk/issues/37
Forwarded: no
---- a/data/transmission-remote-gtk.appdata.xml.in
-+++ b/data/transmission-remote-gtk.appdata.xml.in
-@@ -14,14 +14,10 @@
+--- a/data/io.github.TransmissionRemoteGtk.appdata.xml.in
++++ b/data/io.github.TransmissionRemoteGtk.appdata.xml.in
+@@ -13,14 +13,10 @@
<description>
- <_p>
+ <p>
Transmission Remote Gtk allows you to remotely manage the Transmission BitTorrent client using its RPC interface.
+ It is a full featured client, allowing adding, starting, stopping, removing, verifying, and reannouncing torrents.
+ It also exposes settings for both individual torrents (peer limits, file priorities, tracker settings, etc.) and Transmission as a whole (global limits, download directory, connectivity preferences, etc.)
+ It can also act as a .torrent handler, opening when torrents are downloaded through a web browser.
- </_p>
-- <_p>Features:</_p>
+ </p>
+- <p>Features:</p>
- <ul>
-- <_li>Remotely add (file/url), start, stop, remove, remove and delete, verify, reannounce torrents</_li>
-- <_li>Works as a .torrent handler (eg. from a web browser)</_li>
-- <_li>Set torrent properties such as speed, seed, peer limits, file priorities, add/edit/remove trackers</_li>
-- <_li>Change remote settings like global limits, download directory, and connectivity preferences</_li>
+- <li>Remotely add (file/url), start, stop, remove, remove and delete, verify, reannounce torrents</li>
+- <li>Works as a .torrent handler (eg. from a web browser)</li>
+- <li>Set torrent properties such as speed, seed, peer limits, file priorities, add/edit/remove trackers</li>
+- <li>Change remote settings like global limits, download directory, and connectivity preferences</li>
- </ul>
</description>
<screenshots>