summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@mit.edu>2016-10-23 13:14:58 -0400
committerGravatar Benjamin Barenblat <bbaren@mit.edu>2016-10-23 14:00:22 -0400
commit87bf4c3eb81264270e127fff8f2066f516a49223 (patch)
treed33a0088e00db785c2a8e21459d307148149e080
parent79ebc1009e3ba8d2500033c5ee93093f3d2c8d67 (diff)
Remove references to rss-glib from the build system
to avoid a GPL violation.
-rw-r--r--debian/patches/avoidRssGlib.diff43
-rw-r--r--debian/patches/series1
2 files changed, 44 insertions, 0 deletions
diff --git a/debian/patches/avoidRssGlib.diff b/debian/patches/avoidRssGlib.diff
new file mode 100644
index 0000000..fbc156e
--- /dev/null
+++ b/debian/patches/avoidRssGlib.diff
@@ -0,0 +1,43 @@
+Subject: Don't touch rss-glib if RSS is disabled
+
+rss-glib is licensed under the LGPLv3 or later. src/hig.c, src/hig.h,
+src/torrent-cell-renderer.c, and src/torrent-cell-renderer.h are licensed under
+the GPLv2 only. Therefore, transmission-remote-gtk must be built without RSS to
+avoid a GPL violation.
+
+Disabling RSS with --without-libmrss should be enough to ensure this happens.
+In the interest of defence in depth, however, conditionalize references to
+rss-glib from within the build system. As an added bonus, this speeds up build
+time by not building code which will never get linked.
+
+Author: Benjamin Barenblat <bbaren@mit.edu>
+Bug: https://github.com/transmission-remote-gtk/transmission-remote-gtk/issues/21
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -20,7 +20,10 @@
+ ACLOCAL_AMFLAGS = -I m4
+ AUTOMAKE_OPTIONS = foreign
+ DISTCHECK_CONFIGURE_FLAGS = --disable-desktop-database-update
+-SUBDIRS = extern src po data
++SUBDIRS = src po data
++if HAVE_RSS
++SUBDIRS += extern
++endif
+
+ DISTCLEANFILES = \
+ intltool-extract \
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -143,8 +143,10 @@
+ icon-turtle.h
+
+ transmission_remote_gtk_CPPFLAGS = \
+- -DLOCALEDIR=\""$(localedir)"\" \
+- -I$(top_srcdir)/extern
++ -DLOCALEDIR=\""$(localedir)"\"
++if HAVE_RSS
++transmission_remote_gtk_CPPFLAGS += -I$(top_srcdir)/extern
++endif
+
+ transmission_remote_gtk_CFLAGS = \
+ $(TRG_CFLAGS) \
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..13d6d9c
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+avoidRssGlib.diff