summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index e05728f..2d7fce1 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -2,18 +2,18 @@ dist_man_MANS = lsrc.1 mkrc.1 rcdn.1 rcup.1 rcrc.5 rcm.7
###### manpages as HTML
release_build_man_html:
- ([ -d gh-pages ] || git clone --branch gh-pages --single-branch .. gh-pages) && \
+ ([ -d $(abs_top_builddir)/gh-pages ] || git clone --branch gh-pages --single-branch .. $(abs_top_builddir)/gh-pages) && \
for i in $(dist_man_MANS); do \
- mandoc -Thtml -Oman=%N.%S.html $$i > gh-pages/$$i.html ; \
+ mandoc -Thtml -Oman=%N.%S.html $$i > $(abs_top_builddir)/gh-pages/$$i.html ; \
done && \
- cd gh-pages && \
+ cd $(abs_top_builddir)/gh-pages && \
cp rcm.7.html index.html && \
git add -A && \
git commit -m "HTML documentation for $(PACKAGE_VERSION)"
release_push_man_html:
- cd gh-pages && \
+ cd $(abs_top_builddir)/gh-pages && \
git push -f $(ORIGIN_URL) gh-pages
release_clean_man_html:
- rm -rf gh-pages
+ rm -rf $(abs_top_builddir)/gh-pages