summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/contributors.patch13
-rw-r--r--debian/patches/macos.patch52
-rw-r--r--debian/patches/python3.patch10
-rw-r--r--debian/patches/series4
-rw-r--r--debian/patches/shebang.patch40
5 files changed, 119 insertions, 0 deletions
diff --git a/debian/patches/contributors.patch b/debian/patches/contributors.patch
new file mode 100644
index 0000000..49e0354
--- /dev/null
+++ b/debian/patches/contributors.patch
@@ -0,0 +1,13 @@
+From: Benjamin Barenblat <bbaren@debian.org>
+Subject: Remove CONTRIBUTORS section from rcm.7
+Forwarded: not-needed
+
+See README.Debian.
+--- a/autogen.sh
++++ b/autogen.sh
+@@ -3,4 +3,4 @@
+ aclocal &&
+ autoconf &&
+ automake --add-missing --copy &&
+- ./maint/autocontrib man/rcm.7.mustache
++ sed -n '/.Sh CONTRIBUTORS/q; p' man/rcm.7.mustache >man/rcm.7
diff --git a/debian/patches/macos.patch b/debian/patches/macos.patch
new file mode 100644
index 0000000..b17977b
--- /dev/null
+++ b/debian/patches/macos.patch
@@ -0,0 +1,52 @@
+From: Benjamin Barenblat <bbaren@debian.org>
+Subject: Remove references to macOS from documentation
+Forwarded: not-needed
+--- a/man/lsrc.1
++++ b/man/lsrc.1
+@@ -181,16 +181,6 @@
+ and
+ .Lk http://thoughtbot.se thoughtbot
+ .Sh BUGS
+-For macOS systems, we strongly encourage the use of the
+-.Va HOSTNAME
+-variable in your
+-.Xr rcrc 5 .
+-We use the
+-.Xr hostname 1
+-program to determine the unique identifier for the host. This program is
+-not specified by POSIX and can vary by system. On macOS the hostname is
+-unpredictable, and can even change as part of the DHCP handshake.
+-.Pp
+ There are a few bugs around shell globs. Anything involving an exclude
+ pattern is unpredictable, so use
+ .Fl v
+--- a/man/rcm.7.mustache
++++ b/man/rcm.7.mustache
+@@ -244,10 +244,6 @@
+ flag.
+ .Pp
+ .Dl mkrc -B eggplant .rcrc
+-.Pp
+-macOS users should see the
+-.Sx BUGS
+-section for more details.
+ .
+ .Sh STANDALONE INSTALLATION SCRIPT
+ .
+@@ -301,16 +297,6 @@
+ .An "Mike Burns" Aq Mt mburns@thoughtbot.com
+ and
+ .Lk http://thoughtbot.se thoughtbot
+-.Sh BUGS
+-For macOS systems, we strongly encourage the use of the
+-.Va HOSTNAME
+-variable in your
+-.Xr rcrc 5 .
+-We use the
+-.Xr hostname 1
+-program to determine the unique identifier for the host. This program is
+-not specified by POSIX and can vary by system. On macOS, the hostname is
+-unpredictable, and can even change as part of the DHCP handshake.
+ .Sh CONTRIBUTORS
+ .An -split
+ {{#contributors}}
diff --git a/debian/patches/python3.patch b/debian/patches/python3.patch
new file mode 100644
index 0000000..cfa505e
--- /dev/null
+++ b/debian/patches/python3.patch
@@ -0,0 +1,10 @@
+From: Benjamin Barenblat <bbaren@debian.org>
+Subject: Use Python 3
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -51,4 +51,4 @@
+ dist_check_SCRIPTS = $(TESTS)
+ dist_check_DATA = test/helper.sh
+
+-LOG_COMPILER = cram
++LOG_COMPILER = cram3
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..d5413b6
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,4 @@
+contributors.patch
+macos.patch
+shebang.patch
+python3.patch
diff --git a/debian/patches/shebang.patch b/debian/patches/shebang.patch
new file mode 100644
index 0000000..9366b9b
--- /dev/null
+++ b/debian/patches/shebang.patch
@@ -0,0 +1,40 @@
+From: Benjamin Barenblat <bbaren@debian.org>
+Subject: Always use /bin/sh to run rcm
+Forwarded: not-needed
+
+rcm only requires a POSIX-compliant shell – not Bash. The various sh
+options in Debian are POSIX-compliant, and many of them are
+substantially faster than Bash. Force rcm to run under /bin/sh,
+regardless of what shell’s interpreting the configure script.
+--- a/bin/lsrc.in
++++ b/bin/lsrc.in
+@@ -1,4 +1,4 @@
+-#!@SHELL@
++#!/bin/sh
+
+ : ${RCM_LIB:=$(dirname "$0")/../share/rcm}
+ . "$RCM_LIB/rcm.sh"
+--- a/bin/mkrc.in
++++ b/bin/mkrc.in
+@@ -1,4 +1,4 @@
+-#!@SHELL@
++#!/bin/sh
+
+ : ${RCM_LIB:=$(dirname "$0")/../share/rcm}
+ . "$RCM_LIB/rcm.sh"
+--- a/bin/rcdn.in
++++ b/bin/rcdn.in
+@@ -1,4 +1,4 @@
+-#!@SHELL@
++#!/bin/sh
+
+ : ${RCM_LIB:=$(dirname "$0")/../share/rcm}
+ . "$RCM_LIB/rcm.sh"
+--- a/bin/rcup.in
++++ b/bin/rcup.in
+@@ -1,4 +1,4 @@
+-#!@SHELL@
++#!/bin/sh
+
+ : ${RCM_LIB:=$(dirname "$0")/../share/rcm}
+ . "$RCM_LIB/rcm.sh"