summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorGravatar Mike Burns <mike@mike-burns.com>2014-05-30 16:53:57 +0200
committerGravatar Mike Burns <mike@mike-burns.com>2014-07-09 11:10:04 +0200
commit82f59f31ceef20a262846fc1912de86b9d2df677 (patch)
tree1e1dc4154f767bc3cfa8fc18aee4aa3247cc88ed /test/Makefile.am
parentff2aa079062c7471c39590abf33d3f38b0c4abc7 (diff)
Allow the user to override SYMLINK_DIRS with -s
This adds a `-s` that can be used to override the `SYMLINK_DIRS` config, or the `-S` flag, to lsrc(1), mkrc(1), rcup(1), and rcdn(1). The `-s` flag is the opposite of -S: any argument, if it is a directory, is not symlinked but instead recurred down.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 7e067e4..afa2631 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -4,6 +4,7 @@ TESTS = \
lsrc-hostname.t \
lsrc-sigils.t \
lsrc.t \
+ lsrc-symlink-dirs.t \
lsrc-tags.t \
lsrc-usage.t \
mkrc-alternate-dotfiles-dir.t \
@@ -11,6 +12,7 @@ TESTS = \
mkrc-host-file.t \
mkrc-hostname.t \
mkrc-simple-output.t \
+ mkrc-symlink-dirs.t \
mkrc-tagged-file.t \
mkrc-usage.t \
rcrc-custom.t \
@@ -18,6 +20,7 @@ TESTS = \
rcrc.t \
rcup-link-files.t \
rcup-hostname.t \
+ rcup-symlink-dirs.t \
rcup-usage.t
dist_check_SCRIPTS = $(TESTS)