summaryrefslogtreecommitdiff
path: root/man
diff options
context:
space:
mode:
authorGravatar Mike Burns <mike@mike-burns.com>2014-02-20 15:49:36 +0100
committerGravatar Mike Burns <mike@mike-burns.com>2014-02-26 17:49:05 +0100
commit64c8e0c87e02e3a05631d67c9d3072ca87234711 (patch)
treebd403d4a6513a96e68adbbabbdd92df6fc1b6ea2 /man
parent0edd365a507d716690ba7e7638681a7f9a61f8b9 (diff)
Start bringing in the Makefile.am from gitsh
It introduces the `Makefile.am` from gitsh, and abstracts it a bit. This `Makefile.am`, or most of it, could be dropped into gitsh again. How to use it is documented in `DEVELOPERS.md`. The whole release process is more consistent and simple: `make release` to build a tarball, Homebrew, Arch, Debian, HTML (from manpages), and tag it, pushed to the various repos, and with cleanup. The `release` target is composed of smaller targets that stack well.
Diffstat (limited to 'man')
-rw-r--r--man/Makefile.am20
1 files changed, 19 insertions, 1 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 0674e27..e05728f 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -1 +1,19 @@
-man_MANS = lsrc.1 mkrc.1 rcdn.1 rcup.1 rcrc.5 rcm.7
+dist_man_MANS = lsrc.1 mkrc.1 rcdn.1 rcup.1 rcrc.5 rcm.7
+
+###### manpages as HTML
+release_build_man_html:
+ ([ -d gh-pages ] || git clone --branch gh-pages --single-branch .. gh-pages) && \
+ for i in $(dist_man_MANS); do \
+ mandoc -Thtml -Oman=%N.%S.html $$i > gh-pages/$$i.html ; \
+ done && \
+ cd gh-pages && \
+ cp rcm.7.html index.html && \
+ git add -A && \
+ git commit -m "HTML documentation for $(PACKAGE_VERSION)"
+
+release_push_man_html:
+ cd gh-pages && \
+ git push -f $(ORIGIN_URL) gh-pages
+
+release_clean_man_html:
+ rm -rf gh-pages