summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGravatar Mike Burns <mike@mike-burns.com>2014-02-20 15:49:36 +0100
committerGravatar Mike Burns <mike@mike-burns.com>2014-02-26 17:49:05 +0100
commit64c8e0c87e02e3a05631d67c9d3072ca87234711 (patch)
treebd403d4a6513a96e68adbbabbdd92df6fc1b6ea2 /debian
parent0edd365a507d716690ba7e7638681a7f9a61f8b9 (diff)
Start bringing in the Makefile.am from gitsh
It introduces the `Makefile.am` from gitsh, and abstracts it a bit. This `Makefile.am`, or most of it, could be dropped into gitsh again. How to use it is documented in `DEVELOPERS.md`. The whole release process is more consistent and simple: `make release` to build a tarball, Homebrew, Arch, Debian, HTML (from manpages), and tag it, pushed to the various repos, and with cleanup. The `release` target is composed of smaller targets that stack well.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog29
-rw-r--r--debian/compat2
-rw-r--r--debian/control12
-rw-r--r--debian/copyright2
-rw-r--r--debian/docs1
-rw-r--r--debian/files1
-rw-r--r--debian/rcm.substvars1
-rwxr-xr-xdebian/rules3
8 files changed, 40 insertions, 11 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..5e196b9
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,29 @@
+rcm (1.2.1-1) UNRELEASED; urgency=medium
+
+ * Re-visit the Debian packaging.
+
+ -- Mike Burns <mburns@thoughtbot.com> Sat, 22 Feb 2014 00:49:32 +0100
+
+rcm (1.2.0-1) unstable; urgency=medium
+
+ * New upstream release
+
+ -- Mike Burns <mburns@thoughtbot.com> Mon, 03 Feb 2014 16:58:33 +0200
+
+rcm (1.1.0-1) unstable; urgency=medium
+
+ * New upstream release.
+
+ -- Mike Burns <mburns@thoughtbot.com> Mon, 05 Aug 2013 16:43:33 +0200
+
+rcm (1.0.0-1) unstable; urgency=medium
+
+ * New upstream release.
+
+ -- Mike Burns <mburns@thoughtbot.com> Tue, 01 Aug 2013 16:43:33 +0200
+
+rcm (0.0.2-1) unstable; urgency=medium
+
+ * New upstream release.
+
+ -- Mike Burns <mburns@thoughtbot.com> Tue, 23 Jul 2013 16:43:33 +0200
diff --git a/debian/compat b/debian/compat
index 45a4fb7..ec63514 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-8
+9
diff --git a/debian/control b/debian/control
index 02f1b10..bb141f5 100644
--- a/debian/control
+++ b/debian/control
@@ -1,12 +1,12 @@
Source: rcm
Section: utils
-Priority: extra
+Priority: optional
Maintainer: Mike Burns <mburns@thoughtbot.com>
-Build-Depends: debhelper (>= 8.0.0)
-Standards-Version: 3.9.3
-Homepage: http://github.com/mike-burns/rcm
-Vcs-Git: git://github.com/mike-burns/rcm.git
-Vcs-Browser: http://github.com/mike-burns/rcm
+Build-Depends: debhelper (>= 9)
+Standards-Version: 3.9.4
+Homepage: http://thoughtbot.github.io/rcm
+Vcs-Git: git://github.com/thoughtbot/rcm.git
+Vcs-Browser: http://github.com/thoughtbot/rcm
Package: rcm
Architecture: all
diff --git a/debian/copyright b/debian/copyright
index 3fa949f..428f888 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,6 +1,6 @@
Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Upstream-Name: rcm
-Source: git@github.com:mike-burns/rcm.git
+Source: git@github.com:thoughtbot/rcm.git
Files: *
Copyright: 2013 Mike Burns <mburns@thoughtbot.com>
diff --git a/debian/docs b/debian/docs
deleted file mode 100644
index b43bf86..0000000
--- a/debian/docs
+++ /dev/null
@@ -1 +0,0 @@
-README.md
diff --git a/debian/files b/debian/files
deleted file mode 100644
index 39ac931..0000000
--- a/debian/files
+++ /dev/null
@@ -1 +0,0 @@
-rcm_0.0.2-1_all.deb utils extra
diff --git a/debian/rcm.substvars b/debian/rcm.substvars
deleted file mode 100644
index abd3ebe..0000000
--- a/debian/rcm.substvars
+++ /dev/null
@@ -1 +0,0 @@
-misc:Depends=
diff --git a/debian/rules b/debian/rules
index c259a57..f7f9dcb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -19,3 +19,6 @@ export DH_OPTIONS
%:
dh $@
+
+override_dh_installchangelogs:
+ dh_installchangelogs NEWS.md