summaryrefslogtreecommitdiff
path: root/arch/PKGBUILD
diff options
context:
space:
mode:
authorGravatar Mike Burns <mike@mike-burns.com>2014-02-20 15:49:36 +0100
committerGravatar Mike Burns <mike@mike-burns.com>2014-02-26 17:49:05 +0100
commit64c8e0c87e02e3a05631d67c9d3072ca87234711 (patch)
treebd403d4a6513a96e68adbbabbdd92df6fc1b6ea2 /arch/PKGBUILD
parent0edd365a507d716690ba7e7638681a7f9a61f8b9 (diff)
Start bringing in the Makefile.am from gitsh
It introduces the `Makefile.am` from gitsh, and abstracts it a bit. This `Makefile.am`, or most of it, could be dropped into gitsh again. How to use it is documented in `DEVELOPERS.md`. The whole release process is more consistent and simple: `make release` to build a tarball, Homebrew, Arch, Debian, HTML (from manpages), and tag it, pushed to the various repos, and with cleanup. The `release` target is composed of smaller targets that stack well.
Diffstat (limited to 'arch/PKGBUILD')
-rw-r--r--arch/PKGBUILD39
1 files changed, 0 insertions, 39 deletions
diff --git a/arch/PKGBUILD b/arch/PKGBUILD
deleted file mode 100644
index af5503e..0000000
--- a/arch/PKGBUILD
+++ /dev/null
@@ -1,39 +0,0 @@
-# Maintainer: Pat Brisbin <pbrisbin@gmail.com>
-_gitname=rcm
-pkgname=$_gitname-git
-pkgver=0.0.0
-pkgrel=1
-pkgdesc="rc file (dotfile) management"
-arch=('any')
-url="https://github.com/mike-burns/rcm"
-license=('BSD')
-makedepends=('git')
-source=('git://github.com/mike-burns/rcm')
-md5sums=('SKIP')
-
-pkgver() {
- cd $_gitname
-
- git describe --always | sed 's|-|.|g'
-}
-
-build() {
- cd $_gitname
-
- aclocal
- automake --add-missing --copy
- autoconf
-
- ./configure --prefix=/usr
- make
-}
-
-package() {
- cd $_gitname
-
- make DESTDIR="$pkgdir/" install
-
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_gitname/LICENSE"
-}
-
-# vim:set ts=2 sw=2 et: