summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar Mike Burns <mike@mike-burns.com>2013-06-07 10:49:17 +0200
committerGravatar Mike Burns <mike@mike-burns.com>2013-06-07 10:49:17 +0200
commit3c6cbc343d19e221756be024ba8d5bf2632c38d7 (patch)
tree0283693945dd131924d6e0b005ca588ff201d9f1 /Makefile
Initial commit
This adds mkrc and rcup, along with a Makefile to handle installation. `rcup` is for installing files from the `~/.dotfiles` repo. It allows for tagged files and host-specific files, and can install/update one-off files. `mkrc` is for moving a normal file into the dotfiles repo.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..df46731
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,7 @@
+PREFIX=/usr/local
+
+install:
+ install -m 0755 bin/mkrc $(PREFIX)/bin
+ install -m 0755 bin/rcup $(PREFIX)/bin
+
+.PHONY: install