summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar Mike Burns <mike@mike-burns.com>2013-07-10 23:50:11 +0200
committerGravatar Mike Burns <mike@mike-burns.com>2013-07-12 21:53:07 +0200
commit30e09856846e482d1bc805645956d2cfe202e0cc (patch)
treeabe89042ab5df3af14faf1a203dfda81d095bd18 /Makefile
parent75586ddbd84bbce167ae981a674d60743acb857b (diff)
Add lsrc
The `lsrc` command works just like the `rcup` command but instead of making symlinks and directories, it just lists all the files that would be symlinks. It prints the destination (e.g. `~/.foo`) and the source (`~/.dotfiles/foo`), separated by a colon. Re-write `rcup` in terms of `lsrc`.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index f4c2b5c..5a05334 100644
--- a/Makefile
+++ b/Makefile
@@ -7,8 +7,10 @@ install:
install -dm 0755 $(PREFIX)/libexec/rcm
install -m 0755 bin/mkrc $(PREFIX)/bin
install -m 0755 bin/rcup $(PREFIX)/bin
+ install -m 0755 bin/lsrc $(PREFIX)/bin
install -m 0644 man/man1/rcup.1 $(PREFIX)/share/man/man1
install -m 0644 man/man1/mkrc.1 $(PREFIX)/share/man/man1
+ install -m 0644 man/man1/lsrc.1 $(PREFIX)/share/man/man1
install -m 0644 man/man5/rcrc.5 $(PREFIX)/share/man/man5
install -m 0644 libexec/rcm/rcm.sh $(PREFIX)/libexec/rcm