summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Mike Burns <mike@mike-burns.com>2014-05-30 14:06:16 +0200
committerGravatar Mike Burns <mike@mike-burns.com>2014-05-30 14:06:16 +0200
commitcda41b5f2a5e9ab38e340f802503c745f77e681e (patch)
treeed0fd63434135850388ce1e7cbbb302a8f715c8e
parentd51f8ace755c6530082785600639ba8000977f48 (diff)
Make the tests run again
The `check` target was broken because of `dist_TESTS`; it _must_ be just `TESTS`, not distributed. Use `dist_check_SCRIPTS` instead so that they can be packaged as scripts for checking the system.
-rw-r--r--test/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 9ec3264..7e067e4 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,4 +1,4 @@
-dist_TESTS = \
+TESTS = \
lsrc-dotfiles-dirs.t \
lsrc-excludes.t \
lsrc-hostname.t \
@@ -20,4 +20,6 @@ dist_TESTS = \
rcup-hostname.t \
rcup-usage.t
+dist_check_SCRIPTS = $(TESTS)
+
LOG_COMPILER = cram