summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Mike Burns <mike@mike-burns.com>2014-03-07 16:26:47 +0100
committerGravatar Mike Burns <mike@mike-burns.com>2014-03-07 16:26:47 +0100
commit28f1a140d877078dbcd0359834c17973a3b448d6 (patch)
treea54ce9a8e3240033eb4878a2fa3fa6e10d1240df
parentfe64c628a05a432f71573e93acc842cbedd418da (diff)
Last-minute changesv1.2.1
* Debian package has a -2 in its filename. Of course. * Build HTML docs in the top-level gh-pages directory.
-rw-r--r--README.md4
-rw-r--r--man/Makefile.am10
2 files changed, 7 insertions, 7 deletions
diff --git a/README.md b/README.md
index 93970a2..56d026b 100644
--- a/README.md
+++ b/README.md
@@ -17,8 +17,8 @@ Arch Linux:
Debian-based (including Ubuntu):
- wget https://thoughtbot.github.io/rcm/debs/rcm_1.2.1_all.deb
- sudo dpkg -i rcm_1.2.1_all.deb
+ wget https://thoughtbot.github.io/rcm/debs/rcm_1.2.1-2_all.deb
+ sudo dpkg -i rcm_1.2.1-2_all.deb
Gentoo-based (including Funtoo):
diff --git a/man/Makefile.am b/man/Makefile.am
index e05728f..2d7fce1 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -2,18 +2,18 @@ dist_man_MANS = lsrc.1 mkrc.1 rcdn.1 rcup.1 rcrc.5 rcm.7
###### manpages as HTML
release_build_man_html:
- ([ -d gh-pages ] || git clone --branch gh-pages --single-branch .. gh-pages) && \
+ ([ -d $(abs_top_builddir)/gh-pages ] || git clone --branch gh-pages --single-branch .. $(abs_top_builddir)/gh-pages) && \
for i in $(dist_man_MANS); do \
- mandoc -Thtml -Oman=%N.%S.html $$i > gh-pages/$$i.html ; \
+ mandoc -Thtml -Oman=%N.%S.html $$i > $(abs_top_builddir)/gh-pages/$$i.html ; \
done && \
- cd gh-pages && \
+ cd $(abs_top_builddir)/gh-pages && \
cp rcm.7.html index.html && \
git add -A && \
git commit -m "HTML documentation for $(PACKAGE_VERSION)"
release_push_man_html:
- cd gh-pages && \
+ cd $(abs_top_builddir)/gh-pages && \
git push -f $(ORIGIN_URL) gh-pages
release_clean_man_html:
- rm -rf gh-pages
+ rm -rf $(abs_top_builddir)/gh-pages