summaryrefslogtreecommitdiff
path: root/plugins
diff options
context:
space:
mode:
Diffstat (limited to 'plugins')
-rw-r--r--plugins/alsa/alsa.c1
-rw-r--r--plugins/converter/Makefile4
-rw-r--r--plugins/gtkui/gtkui.c6
-rw-r--r--plugins/gtkui/prefwin.c21
-rw-r--r--plugins/nullout/nullout.c1
-rw-r--r--plugins/oss/oss.c1
6 files changed, 6 insertions, 28 deletions
diff --git a/plugins/alsa/alsa.c b/plugins/alsa/alsa.c
index 68981512..ea622981 100644
--- a/plugins/alsa/alsa.c
+++ b/plugins/alsa/alsa.c
@@ -699,7 +699,6 @@ static DB_output_t plugin = {
DB_PLUGIN_SET_API_VERSION
.plugin.version_major = 1,
.plugin.version_minor = 0,
- .plugin.nostop = 1,
.plugin.type = DB_PLUGIN_OUTPUT,
.plugin.name = "ALSA output plugin",
.plugin.descr = "plays sound through linux standard alsa library",
diff --git a/plugins/converter/Makefile b/plugins/converter/Makefile
index 2b062f84..7cd742a0 100644
--- a/plugins/converter/Makefile
+++ b/plugins/converter/Makefile
@@ -3,9 +3,9 @@ GUI_OUT=converter_gtkui.so
CC=gcc
-CFLAGS+=-Wall -D_GNU_SOURCE -std=c99 -g -I../..
+CFLAGS+=-Wall -D_GNU_SOURCE -std=c99 -fPIC -g -I../..
-LDFLAGS+=-module -shared -fPIC
+LDFLAGS+=-module -shared
CONVERTER_SOURCES=converter.c
GUI_SOURCES=convgui.c interface.c support.c
diff --git a/plugins/gtkui/gtkui.c b/plugins/gtkui/gtkui.c
index e8f41e64..abd6a720 100644
--- a/plugins/gtkui/gtkui.c
+++ b/plugins/gtkui/gtkui.c
@@ -1164,11 +1164,13 @@ gtkui_start (void) {
return 0;
}
+static DB_plugin_t *supereq_plugin;
+
gboolean
gtkui_connect_cb (void *none) {
// equalizer
GtkWidget *eq_mi = lookup_widget (mainwin, "view_eq");
- if (!deadbeef->plug_get_for_id ("supereq")) {
+ if (!supereq_plugin) {
gtk_widget_hide (GTK_WIDGET (eq_mi));
}
else {
@@ -1196,6 +1198,7 @@ gtkui_connect_cb (void *none) {
static int
gtkui_connect (void) {
+ supereq_plugin = deadbeef->plug_get_for_id ("supereq");
// need to do it in gtk thread
g_idle_add (gtkui_connect_cb, NULL);
@@ -1262,7 +1265,6 @@ static ddb_gtkui_t plugin = {
.gui.plugin.api_vminor = DB_API_VERSION_MINOR,
.gui.plugin.version_major = 1,
.gui.plugin.version_minor = 0,
- .gui.plugin.nostop = 1,
.gui.plugin.type = DB_PLUGIN_MISC,
.gui.plugin.id = "gtkui",
.gui.plugin.name = "Standard GTK2 user interface",
diff --git a/plugins/gtkui/prefwin.c b/plugins/gtkui/prefwin.c
index 163459d9..38167165 100644
--- a/plugins/gtkui/prefwin.c
+++ b/plugins/gtkui/prefwin.c
@@ -67,27 +67,6 @@ gtk_enum_sound_callback (const char *name, const char *desc, void *userdata) {
}
void
-on_plugin_active_toggled (GtkCellRendererToggle *cell_renderer, gchar *path, GtkTreeModel *model) {
- GtkTreePath *p = gtk_tree_path_new_from_string (path);
- if (p) {
- int *indices = gtk_tree_path_get_indices (p);
- //gtk_tree_path_free (p); // wtf?? gtk crashes on this
- if (indices) {
- DB_plugin_t **plugins = deadbeef->plug_get_list ();
- DB_plugin_t *plug = plugins[*indices];
- gboolean state;
- GtkTreeIter iter;
- gtk_tree_model_get_iter (model, &iter, p);
- gtk_tree_model_get (model, &iter, 0, &state, -1);
- if (!deadbeef->plug_activate (plug, !state)) {
- gtk_list_store_set (GTK_LIST_STORE (model), &iter, 0, !state, -1);
- }
- }
- g_free (indices);
- }
-}
-
-void
preferences_fill_soundcards (void) {
if (!prefwin) {
return;
diff --git a/plugins/nullout/nullout.c b/plugins/nullout/nullout.c
index 627f8a98..2d07a84d 100644
--- a/plugins/nullout/nullout.c
+++ b/plugins/nullout/nullout.c
@@ -192,7 +192,6 @@ static DB_output_t plugin = {
DB_PLUGIN_SET_API_VERSION
.plugin.version_major = 1,
.plugin.version_minor = 0,
- .plugin.nostop = 1,
.plugin.type = DB_PLUGIN_OUTPUT,
.plugin.name = "null output plugin",
.plugin.descr = "doesn't play anything",
diff --git a/plugins/oss/oss.c b/plugins/oss/oss.c
index b78a2290..817c62f6 100644
--- a/plugins/oss/oss.c
+++ b/plugins/oss/oss.c
@@ -307,7 +307,6 @@ static DB_output_t plugin = {
DB_PLUGIN_SET_API_VERSION
.plugin.version_major = 1,
.plugin.version_minor = 0,
- .plugin.nostop = 0,
.plugin.type = DB_PLUGIN_OUTPUT,
.plugin.id = "oss",
.plugin.name = "OSS output plugin",