summaryrefslogtreecommitdiff
path: root/plugins/sid/sidplay-libs/unix/config.h
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/sid/sidplay-libs/unix/config.h')
-rw-r--r--plugins/sid/sidplay-libs/unix/config.h108
1 files changed, 108 insertions, 0 deletions
diff --git a/plugins/sid/sidplay-libs/unix/config.h b/plugins/sid/sidplay-libs/unix/config.h
new file mode 100644
index 00000000..ee1de9e8
--- /dev/null
+++ b/plugins/sid/sidplay-libs/unix/config.h
@@ -0,0 +1,108 @@
+/* unix/config.h. Generated by configure. */
+/* unix/config.h.in. Generated from configure.ac by autoheader. */
+
+/* Define if the C++ compiler supports BOOL */
+#define HAVE_BOOL
+
+/* Define to 1 if you have the <dlfcn.h> header file. */
+#define HAVE_DLFCN_H 1
+
+/* Define if your C++ compiler implements exception-handling. */
+/* #undef HAVE_EXCEPTIONS */
+
+/* Define to 1 if you have the <inttypes.h> header file. */
+#define HAVE_INTTYPES_H 1
+
+/* Define if standard member ``ios::binary'' is called ``ios::bin''. */
+/* #undef HAVE_IOS_BIN */
+
+/* Define if ``ios::openmode'' is supported. */
+/* #undef HAVE_IOS_OPENMODE */
+
+/* Define to 1 if you support file names longer than 14 characters. */
+#define HAVE_LONG_FILE_NAMES 1
+
+/* Define to 1 if you have the <memory.h> header file. */
+#define HAVE_MEMORY_H 1
+
+/* Define to 1 if you have the <stdbool.h> header file. */
+#define HAVE_STDBOOL_H 1
+
+/* Define to 1 if you have the <stdint.h> header file. */
+#define HAVE_STDINT_H 1
+
+/* Define to 1 if you have the <stdlib.h> header file. */
+#define HAVE_STDLIB_H 1
+
+/* Define if you have the strcasecmp function. */
+#define HAVE_STRCASECMP
+
+/* Define to 1 if you have the <strings.h> header file. */
+#define HAVE_STRINGS_H 1
+
+/* Define to 1 if you have the <string.h> header file. */
+#define HAVE_STRING_H 1
+
+/* Define if you have the strncasecmp function. */
+#define HAVE_STRNCASECMP
+
+/* Define if you have the <strstrea.h> header file. */
+/* #undef HAVE_STRSTREA_H */
+
+/* Define to 1 if you have the <sys/stat.h> header file. */
+#define HAVE_SYS_STAT_H 1
+
+/* Define to 1 if you have the <sys/types.h> header file. */
+#define HAVE_SYS_TYPES_H 1
+
+/* Define to 1 if you have the <unistd.h> header file. */
+#define HAVE_UNISTD_H 1
+
+/* Name of package */
+#define PACKAGE "libsidplay"
+
+/* Define to the address where bug reports for this package should be sent. */
+#define PACKAGE_BUGREPORT ""
+
+/* Define to the full name of this package. */
+#define PACKAGE_NAME ""
+
+/* Define to the full name and version of this package. */
+#define PACKAGE_STRING ""
+
+/* Define to the one symbol short name of this package. */
+#define PACKAGE_TARNAME ""
+
+/* Define to the version of this package. */
+#define PACKAGE_VERSION ""
+
+/* The size of a `char', as computed by sizeof. */
+#define SIZEOF_CHAR 1
+
+/* The size of a `int', as computed by sizeof. */
+#define SIZEOF_INT 4
+
+/* The number of bytes in type long */
+/* #undef SIZEOF_LONG */
+
+/* The size of a `long int', as computed by sizeof. */
+#define SIZEOF_LONG_INT 8
+
+/* The number of bytes in type short */
+/* #undef SIZEOF_SHORT */
+
+/* The size of a `short int', as computed by sizeof. */
+#define SIZEOF_SHORT_INT 2
+
+/* The number of bytes in type void* */
+/* #undef SIZEOF_VOIDP */
+
+/* Define to 1 if you have the ANSI C header files. */
+#define STDC_HEADERS 1
+
+/* Version number of package */
+#define VERSION "2.1.0"
+
+/* Define to 1 if your processor stores words with the most significant byte
+ first (like Motorola and SPARC, unlike Intel and VAX). */
+/* #undef WORDS_BIGENDIAN */